close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

help please installing PHP from a newbi?

Thread began 4/14/2009 7:37 pm by markjurisic334977 | Last modified 4/20/2009 8:26 am by David Stringer | 4208 views | 9 replies |

msjj000Beta Tester

help please installing PHP from a newbi?

Hi WA Community,

The plan is to developa dynamic PHP webstore much like the PowerStore. I've done the easy stuff with tools other than Dreamweaver for static sites.

I followed the "web_dev_begin.pdf" instructions and can't seem to get PHP 5.2.9 up and running on Vista Ultimate. PHP ran originally using the installer then l loaded MySQL5.1 using the installer. MySQL worked and afterwards PHP didn't. I uninstalled PHP, rechecked the php.ini file and added the php5isapi.dll using the handling mapper.

Any suggestions?

Thanks, Mark.

Sign in to reply to this post

warrenphillips25336771Beta Tester

Originally Said By: markjurisic334977
  Hi WA Community,

The plan is to developa dynamic PHP webstore much like the PowerStore. I've done the easy stuff with tools other than Dreamweaver for static sites.

I followed the "web_dev_begin.pdf" instructions and can't seem to get PHP 5.2.9 up and running on Vista Ultimate. PHP ran originally using the installer then l loaded MySQL5.1 using the installer. MySQL worked and afterwards PHP didn't. I uninstalled PHP, rechecked the php.ini file and added the php5isapi.dll using the handling mapper.

Any suggestions?

Thanks, Mark.  



try wampserver it installs all neccesary things needed.

Sign in to reply to this post

Justin Nemeth

I agree with Warren, give WAMP a try. It should help streamline the process to get you up an running. en/

Sign in to reply to this post

msjj000Beta Tester

Hi Justin and Warren,

Thanks for the note about WampSevrer. Looks like a great utility. I installed it without any luck. It appears to install. There's a c:\wamp\www\index.php file etc however the Wampserver won't load to configure it as per the wampserver help/instructions page. The only item to choose from the start and app menu in vista is "start wamp server". The windows icon says that wampserver is offline.

Any clues?

Thanks again, Mark.

Sign in to reply to this post

David StringerBeta Tester

Originally Said By: markjurisic334977
  Hi Justin and Warren,

Thanks for the note about WampSevrer. Looks like a great utility. I installed it without any luck. It appears to install. There's a c:\wamp\www\index.php file etc however the Wampserver won't load to configure it as per the wampserver help/instructions page. The only item to choose from the start and app menu in vista is "start wamp server". The windows icon says that wampserver is offline.

Any clues?

Thanks again, Mark.  



Hi Mark,

That is the normal state of Wamp! If you 'Stop all services' it will show a red indicator. If you start it again the red indicator goes.

Have you put a website into the www folder of Wamp and tested it out?

Give this a try first.

Regards,

Sign in to reply to this post

warrenphillips25336771Beta Tester

I agree with david

remember now though all websites need to be stored under the www on wampserver else it will not work, if you need help just ask

Sign in to reply to this post

msjj000Beta Tester

getting php & mysql up and running

Hi Warren & David,

Thanks again.

Not sure why but wampserver now appears to be up and running. I was playing around trying to get adobe fireworks to run and when the system booted it wanted to recover to an earlier working state. since that the server appears up and runnng but wouldn't do so after installing.

l get a tick next to mysql 5.1.33 and php 5.2.9-2.

Any of the *.php files copied to either www or localhost either don't appear to load or l get the "HTTP Error 404.0 - Not Found" message - sorry to be a pain; however any clues?

Cheers, Mark.

Sign in to reply to this post

David StringerBeta Tester

Originally Said By: markjurisic334977
  Any of the *.php files copied to either www or localhost either don't appear to load or l get the "HTTP Error 404.0 - Not Found" message - sorry to be a pain; however any clues?  



Hi Mark,

I presume that the Wamp Server interface appears when you input localhost/

All you should now need to do is follow this with whatever folder it's in, i.e.
SiteName/ and if this has the default file in there - index.php or html, it should appear in your browser.

Just one further point - are your files under the www section of Wamp?

Sign in to reply to this post

msjj000Beta Tester

just a small postscript to the above. when l stop the services the "red light" does come on. When l start the wamp server the red light disappears however it says that the server is offline and the "put online" option returns an error "Could not execute menu item (internal error) [Exception} could not perform service action: The service has not been started"

Sign in to reply to this post

David StringerBeta Tester

Originally Said By: markjurisic334977
  just a small postscript to the above. when l stop the services the "red light" does come on. When l start the wamp server the red light disappears however it says that the server is offline and the "put online" option returns an error "Could not execute menu item (internal error) [Exception} could not perform service action: The service has not been started"  



I'm pretty sure I read somewhere that Put Online refers to putting the programme on the internet, which you don't want. All you want to do with it, is use it on your local drive!

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...