close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

USPS shipping not showing up in cart or on checkout pages.

Thread began 9/29/2009 1:28 am by dan322031 | Last modified 12/22/2009 2:13 pm by Jason Byrnes | 3042 views | 23 replies |

Dan808

USPS shipping not showing up in cart or on checkout pages.

I have been scratching my head over this one for days. I cannot figure out how to get the shipping to show up for US Postal Service.
I searched the forums and learned alot but, did not find how to resolve this.

I am using PowerStore 2. The site is hosted at GoDaddy. www.247sign.com

I pulled all products offered for sale until it shows and includes the shipping charges in the final price.

Thanks for the great software!
Dan

Sign in to reply to this post

Eric Mittman

What is the result you are getting? Is there any failure message or anything like that? What is the URL that is present when you confirm the order? Did you successfully sign up for your account and input the details into the Globals file? Please post back with as much info as you can about what you have done and what the current result is so that we can better determine how to move forward.

Sign in to reply to this post

Dan808

Shipping works.

I called the Post Office and they put me on the "LIVE SERVER". After that everything worked fine.

Sign in to reply to this post

Eric Mittman

Thanks for the update on this, it reminds me of something about the USPS stuff, the rate lookup uses the v3 api, this api does not allow for testing with the test URL's so it must be only used with the live production URL's.

Sign in to reply to this post

jasonkline326722

Hello I have the opposite effect... When I use the test API the checkout process works and I get the shipping quotes. They have switch me over to the LIVE SERVER and the checkout process failed with no errors and reporting is enabled.

Sign in to reply to this post

jasonkline326722

By the way I am using PowerStore 1. Here is the the config:


//Shipping Settings
$WAGLOBAL_Shipping_Enabled = true;
$WAGLOBAL_USPS_User = "XXXXXXXXXXX"; // get this when you sign up for API access
$WAGLOBAL_USPS_Server = "http://production.shippingapis.com/ShippingAPI.dll"; // change this to the live server when you go live

Sign in to reply to this post

Eric Mittman

Are you being taken to the shipping failure page?

To get a better idea of what is gong on you will need to ad in the error message bindings on your shipping failure page. In the bindings panel you will need to expand the USPS and find the error messages and codes then drag them onto your page. The next time you perform a test it should let you know what the problem is. Please post back to us with the error you are getting if you can't resolve the problem.

Sign in to reply to this post

jasonkline326722

Hi Eric...

After adding the error codes to the checkout_failure.php page I don't see any additional error messages besides what I get before adding the error codes.

Transaction Not Completed
We're sorry
Your transaction could not be completed. Either your credit card information or billing address has problems and cannot be processed. Please return to checkout and try again.

Sign in to reply to this post

Eric Mittman

Are you being taken to the shipping failure page? If not what page are you getting to? The page tha tyou are sent to will indicate what part of the checkout you are having the problem with. If you put the bindings for the shipping server behavior on the shipping failure page and do not see any messages it indicates that you are not having a problem with the shipping server behavior. If the error is occurring on your checkout failure page then there is a problem with the local checkout server behavior. If this is the case you should do like you did on the shipping failure page and add in the error codes and messages to the checkout failure page, make sure to add the bindings for your checkout using the bindings panel.

Sign in to reply to this post

jasonkline326722

Hi Eric,

I am being taken to the checkout_failure page.. I added the error codes and here is what I get:

Your transaction could not be completed. Either your credit card information or billing address has problems and cannot be processed. Please return to checkout and try again.-2147219099Rate_Respond.DomesticRatesV2;clsRateV2.UnpackRateNode;SOLServerRates.RateV2_Respond - Missing value for ZipDestination.



????? I missing value for ZipDestination ????

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...