close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

just need to know what this nasty little message means

Thread began 9/29/2009 12:54 am by mehd389652 | Last modified 10/01/2009 12:54 am by neil186288 | 2598 views | 18 replies |

mehd389652

just need to know what this nasty little message means

Still Struggling with this:


Here is what I'm seeing



Warning: mysql_pconnect() [function.mysql-pconnect]: Unknown MySQL server host 'http' (1) in /home/pythoni/public_html/CMS100/Connections/localhost.php on line 9

Fatal error: Unknown MySQL server host 'http' (1) in /home/pythoni/public_html/CMS100/Connections/localhost.php on line 9

obviously means something is not right but what ?

Sign in to reply to this post

Jason ByrnesWebAssist

It means that the MySQL Host address you entered in the localhost.php file is not correct.

double check the value you have given to the following variable:
$hostname_localhost

Check with your host for the correct address to use for the MySQL Server.

Sign in to reply to this post

mehd389652

ok this is my domain right $hostname_localhost =""

I should put my domain name between these quotes is that right ?

and is the syntax

www.mydomain.com

or is it

mydomain.com

or is it none of the above

Sign in to reply to this post

Jason ByrnesWebAssist

No, it is not the domain name. It is the address for the MySQL server.


Check with your host for the correct address to use for the MySQL Server.

Sign in to reply to this post

mehd389652

Why don't you have something in your documentation

That would at least give some clue as to how this looks

I have contacted my host done everything they said

and it still doesn't work. I have now spent 3 days on

this for no results ?

Sign in to reply to this post

neil186288

Have you tried:

$hostname_localhost = "localhost";

That should work fine assuming you have uploaded the localhost.php file to your server.


[With mine, while I'm testing on my local machine, I use:

$hostname_localhost = "www.mydomain.com"; (mydomain is my domain name)

I'm able to use that on my local machine because I have set my username in mySql preferences in my control panel to allow % - which is a wildcard symbol means that it will accept connection from any source.]

But just localhost should be fine for a page that's been uploaded.

Sign in to reply to this post

neil186288

Incidentally, what did your hosting provider tell you to do?

That might help the people here to help you check if you're doing it right.

Sign in to reply to this post

mehd389652

Hi Neil

They told me to use localhost as you suggest.

But "that suggestion" should be in the notes to give newbies

like myself some clue as to what they are on about and

at least vaguely what it looks like?


They should say something like typically this is "localhost" but

check with your host . . . blah blah.


Thank you for your help though Neil and your information was

quite correct although I don't totally understand your access on

your local machine and you sound like your on a PC I'm on a Mac

anyone who says Macs are easy to use is having themselves on ?


But aren't all computers COWS ?


Ciao,


Mike

Sign in to reply to this post

mehd389652

Mike here Jayson

Originally Said By: Jason Byrnes
  It means that the MySQL Host address you entered in the localhost.php file is not correct.

double check the value you have given to the following variable:
$hostname_localhost

Check with your host for the correct address to use for the MySQL Server.  



Mike said:

$hostname_localhost="localhost"

was the reply from the host and the value

Sign in to reply to this post

neil186288

I agree with you entirely Mike,

I sometimes feel that the techie types - especially at WebAssist - are genetically incapable of understanding the difficulties that starters have with all of this stuff. Hence the length of some of these threads - when people have to keep posting back to try to get the 'pros' to explain what their last explanation actually meant. It can be like trying to get blood from a stone around here.

Someone from WebAssist could have simply said, 'have you tried: '$hostname_localhost = "localhost";' ?'

But no, that would be damn obvious for these guys.

Good luck

And yes, computers can be cows.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...