close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Cannot modify header information - headers already sent (Yes, another one of these)

Thread began 9/29/2016 10:47 pm by John | Last modified 10/03/2016 3:03 pm by Ray Borduin | 284 views | 2 replies |

John

Cannot modify header information - headers already sent (Yes, another one of these)

I followed the Web development tutorial: Create a product catalog eCommerce series. Sadly, the following error whenever adding/updating to the dB has plagued me:

( ! ) Warning: Cannot modify header information - headers already sent by (output started at C:\wamp\www\test\Connections\clubquarters.php:6) in C:\wamp\www\test\admin\admin_insert.php on line 65

There are many posts on this subject, and I believe I read and followed all of them. I removed all the spaces/line breaks in the php, as well as all the notes. I removed and reinstalled DataBridge and eCart, and made sure DW is updated. Additionally, I re-ran through the tutorial numerous times and had the same result each time when adding/updating to the dB. Included is the insert.php and connections php pages noted in the Warning, though it occurs on update and when I try to add to cart.

Is it a problem with the placement of the $WA_redirectURL? Does it need to be higher in the code? Is it a problem with using WAMP? (I will sorely be disappointed in myself if you see a space/extra line that I missed causing the error. Like everyone else with this error, which I am certain you are sick of seeing, I spent many hours trying to fix it myself.)

Any assistance is greatly appreciated.

Attached Files
admin_insert.php
clubquarters.php
Sign in to reply to this post

Ray BorduinWebAssist

The message implies that there is something being written to the page on clubquarters.php:line 6.

Is it possible that the connection information is wrong and triggering an error?

Try adding a die(); statement after the connection on line7.

die("here");

Then see if there is something getting written to the page before the word "here" that will be displayed.

I've seen odd issues with corrupted files causing issues like this in the past as well. Perhaps creating a new blank page and copying the data fro the connection file and then overwriting the connection file will fix it. I don't really see the problem with the file either.

Sign in to reply to this post

John

Ray, Thanks for the quick response. I tried adding the die("here"); statement and that resulted in nothing being written before the 'here'. It wasn't the BOM either (forgot to mention I checked that also.) What I ended up doing is removing WAMP and installing a new version. Everything works well now. Not certain what I had configured wrong, but it works now.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...