close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Captcha image does not display

Thread began 6/23/2015 2:07 pm by Charles | Last modified 6/25/2015 7:29 pm by Ray Borduin | 301 views | 5 replies |

Charles

Captcha image does not display

Created pages using SecurityAssist. Captcha image does not display. Read the thread where you suggested to remove semicolon from php.ini file from line that contained 'gd2.' I checked that and there is no semicolon before that line. Any other suggestions?
Using Wamp server and the code created by SA for my registration.php file is
<img src="webassist/captcha/wavt_captchasecurityimages.php?field=Security_Code&amp;noisefreq=15&amp;noisecolor=060606&amp;gridcolor=080808&amp;font=fonts/MOM_T___.TTF&amp;textcolor=040404" alt="Security Code" class="Captcha">

I'll add that I ran the phpinfo,php as suggested in your tutorial and GD is enabled.

Sign in to reply to this post

Ray BorduinWebAssist

What is the URL to the page so I can take a look.

Sign in to reply to this post

Charles

It is on my local wamp server. Since you can't view it there, I have attached a copy of registration.php. Hopefully that's sufficient info for you.

Attached Files
registration.php
Sign in to reply to this post

Ray BorduinWebAssist

There is nothing wrong I can see with the page.

Maybe replace the &amp; in the src with just an &

<img src="webassist/captcha/wavt_captchasecurityimages.php?field=Security_Code&noisefreq=15&noisecolor=060606&gridcolor=080808&font=fonts/MOM_T___.TTF&textcolor=040404" alt="Security Code" class="Captcha">

Could you put it up to a live location so I could view it? I think that may be necessary to debug any further.

Sign in to reply to this post

Charles

Captcha seems to load fine on the live server registration page - see http://outofchaos.net/gsc/www/registration.php
Just can't make it work on my local wamp server. I suppose I can Import the User table from the Live server to trick my test server for testing purposes unless you have another suggestion. Thanks . . .Charlie

Sign in to reply to this post

Ray BorduinWebAssist

It must be an issue with the GD library or freetype installation on your local server. I'm not an expert at server configuration, but if it works on the live site that means it isn't an issue with the code.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...