close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Styling - attached style sheet does not update text box

Thread began 8/19/2009 7:52 am by sales358884 | Last modified 8/20/2009 11:56 am by Jason Byrnes | 2554 views | 3 replies |

sales358884

Styling - attached style sheet does not update text box

Under styling have attached a style sheet and slected the two options in the CSS file to appear. They appear in the Styles drop down list on the web site so that works. However i am unable to get the selected style options to then change the contents of the text box. I wish to limit the style options available to the users.

attached style sheets :-
>>
@charset "utf-8";
/* CSS Document */

/* *******************************************************
KGG Style sheet
******************************************************* */
body
{
background-color: #ffffff;
padding: 5px 5px 5px 5px;
margin: 0px;
}
.Standard
{
font-family: Verdana, Geneva, sans-serif;
color : #000000;
font-size: medium ;
}

.Large
{
font-family: Verdana, Geneva, sans-serif;
color : #000000;
font-size: large;
}
>>
FCEditor config settings :-

FCKConfig.EditorAreaCSS = '../../css_styles/KGG_Styles.css'; // relative to fckeditor/editor/fckeditor.html
FCKConfig.BodyClass = 'Large';
FCKConfig.StylesXmlPath = '../custom/ChairmansBlog_CB_detailStyles1.xml'; // relative to fckeditor/editor/fckeditor.html

Thanks

Chris

Sign in to reply to this post

Jason ByrnesWebAssist

Has the css_styles/KGG_Styles.css file been attached to the page you applied iRite to?


Make sure the page you applied iRite to has a link to the style sheet:
<link href="css_styles/KGG_Styles.css" rel="stylesheet" type="text/css" />

Sign in to reply to this post

CharlieB

Jason,
Yes this has been applied. After your note, I added the 2 entries to the main site style sheet and changed all the settings in Irite to correspond as I know this CSS is being picked up and works, but still no joy. The style box shows the two items I have selected in IRite (under :Edit>Styles[Tab]>available styles) but does not seem to want to apply them to the text in the text box on the web site. Other menu items like bold and italic work ok.

The source code shows the correct entry ie class=&#8221;standard&#8221; in the text field and when you submit the entry the correct style is then displayed, but during editing the changes don&#8217;t appear to be dynamic as with the bold or italic buttons etc.

Sign in to reply to this post

Jason ByrnesWebAssist

I will need a link to the page you have applied iRite to so I can investigate the problem further.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...