close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Problems with Form Builder 2

Thread began 10/27/2010 1:06 pm by p.woodall208922 | Last modified 11/02/2010 10:21 am by studer283031 | 1808 views | 13 replies |

p.woodall208922

Problems with Form Builder 2

Having uninstalled form builder 1 and installed form builder 2 everything seemed to work fine until I needed to use Theme it do make some adjustments, When I clicked on the icon to activate the program I got the error message shown in the attachment.

Also as I have been asked to produce a multilingual web site (English and Spanish) how can I translate the English security questions into Spanish?

I am also concerned by the length of your CSS files. Is it too much trouble to expect you to produce a CSS file for EACH variation of form, e.g. Brassy or Cool, instead of the ridiculaously complex CSS file you offer that covers ALL the variations. At a purchase price of $250 that should be something purchasers should expect by right. This applies to all your other extensions where lazyness has become the order of the day.

Can I ask your designers to endeavour to HELP your Clients rather than causing them totally unnecessary work searching through totally unnecessary reams of CSS properties.
If your designers were methodical, in their approach to design, such a request would not be necessary. This approach goes against ALL the principals of good coding. For example the "cool simple" form has several properties listed for a "datepicker" which is NOT contained on the basic form and indeed would not normally be found on a contact form.
This work should be undertaken by yourselves NOT your Clients.

Regards

Peter

Sign in to reply to this post

YellowCircleWeb

Totally agree with your views on the CSS code Peter.
For your javascript error try deleting the dreamweaver .dat cache file that usually clears javascript errors. There are lots of posts on these forums detailing where this file is located if you don't already know.

Sign in to reply to this post

Ray BorduinWebAssist

The css contains form elements you might not be using on that form because the same .css file could be used for all forms in your site, so just because you don't have a datepicker in this form you still might need it in the css.

Also we allow you to edit the form contents and design (css) separately. So you could add a datepicker to your form at a later date without updating the css, so the css has to be prepared for that.

We do appreciate the feedback and we will be investigating ways to simplify the html and css in future updates.

Sign in to reply to this post

p.woodall208922

Form Builder 2 still not working

Originally Said By: Ray Borduin
  The css contains form elements you might not be using on that form because the same .css file could be used for all forms in your site, so just because you don't have a datepicker in this form you still might need it in the css.

Also we allow you to edit the form contents and design (css) separately. So you could add a datepicker to your form at a later date without updating the css, so the css has to be prepared for that.

We do appreciate the feedback and we will be investigating ways to simplify the html and css in future updates.  



Can you explain where the fault lies? I still get the message as attached to my original question. I did as Ian suggested in the first reply, i.e. deleted the cache file, but that did not resolve the matter. I then tried to uninstall both Theme it and Form Builder 2, via the Adobe Extension Manager, only to find that the blue progress bar only reached around three quarters before stopping - it would not load the extensions however long I waited.

I then decided to find where the extensions were actually stored, and having found them deleted both Theme it and Form Builder 2. I tried the Extension Manager again and this time it loaded all the extensions (without of course Theme it and Form Builder 2). I then installed Form Builder 2 on its own. That worked well but when I try to use Theme it from the menu bar I still get the same message (see attachement).

This should be an easy way to modify the form but clearly if Theme it cannot be accessed.
That it an unnecessary waste of time.

Update - to make matters worse when I click on the HTML icon - it activates the extension and asks for my serial number. I visited my downloads and cut and pasted the serial number inserted it only to find that it was declared invalid.
I have a screenshot but was unable to upload it which is a shame as it shows exactly what happened. Why is this facility no available having made alterations to the original post?

I also asked where I can find your security questions e.g. "What day comes after Thursday?" as I need to translate them into Spanish.

Sign in to reply to this post

Morgan

Got the same problem as you have.
Could not click Theme-It in Form Builder 2 nore on the Theme-It button it self after creating a simpel form.

Get the same JavaScript error

Update:
Unistalled the Theme It extention then tryed Theme It in Formbuilder 2 on that form i did, and it worked.
Installed the Theme-It again and tryed Theme-It on the form again on the form. Got the JavaScript error again.
Tryed Theme-It on another page not created by FormBuilder 2 and it worked fine without any errors.

Will do some more tests.

/Morgan

Sign in to reply to this post

studer283031

warning: chdir()

Dear all

todays morning I ourchased the CSS Form Builder. I have a lot of problems to works with it. First of all, I have a Template, and when I insert a form based on Formbuilder the header is black and all pictures in the Tag header are disappeared. Seccond: This error messages appeared after I submit a form. What goes wrong? Can anyboddy help me?

Sorry for my bad englisch.

Paul

---- Errors-----

Warning: chdir() [function.chdir]: No such file or directory (errno 2) in /home/studerco/public_html/webassist/email/mailformatting_php.php on line 140

Warning: getfrompage(Block_4.php) [function.getfrompage]: failed to open stream: No such file or directory in /home/studerco/public_html/webassist/email/mailformatting_php.php on line 142

Warning: getfrompage(Block_4.php) [function.getfrompage]: failed to open stream: No such file or directory in /home/studerco/public_html/webassist/email/mailformatting_php.php on line 142

Fatal error: getfrompage() [function.require]: Failed opening required 'Block_4.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/studerco/public_html/webassist/email/mailformatting_php.php on line 142

Sign in to reply to this post

CraigRBeta Tester

the file mailformatting_php.php isn't on your server or is not on the path specified.

upload the file to your server or change the path and you should be good to go,

Sign in to reply to this post

studer283031

CSS Menu Writer 2 and CSS Form Builder

Dera all

In the past I am working with the CSS Menue Writer 2 without any problems. Since I installed the CSS Form Builder I have problems. See my Menu on the following Side:
index.php
If you klick "Dienstleistungen -> Schulungen -> MS Windows" it works. But after you klick "Dienstleistungen -> Schulungen -> Internet" an error Messages appear. But, when you first go back and klich "Home" and afterthem klick "Dienstleistungen -> Schulungen -> Internet" it works. I don't have any ideas why.

CSS Formbuilder (bought Yesteray)
Please klick on Kontakt. Why is there a lot of empty Lines, before the form beginns? What do I wrong? I spend a lot of times, but no solutions was found. Could you help me please!
Next Questions: Is there a possibility to change the Datepicker to the Form dd.mm.yyyy?
Thanks in Advance

Paul from Switzerland

Sign in to reply to this post

studer283031

Originally Said By: CraigR
  the file mailformatting_php.php isn't on your server or is not on the path specified.

upload the file to your server or change the path and you should be good to go,  



-------------------

Thanks for your Help

Paul

Sign in to reply to this post

neilo

The reason that the menu is having problems is that the menu include file (CSSMenuWriter/cssmw/menu.php) is being called from pages that exist in different levels of your site structure.

Your menu.php file menu structure is:

<ul class="level-0" id="cssmw">
<li><span><a href="/index.php">Home</a></span></li>
<li class="parent"><span><a href="#">Dienstleistungen</a></span>
<ul class="level-1">
<li><a href="../../dienstleistung/projektmanagement/scb_pm.php">Projektmanagement</a></li>
<li class="parent"><a href="#">Schulung</a>
<ul class="level-2">
<li><a href="../../dienstleistung/schulung/msoffice/scb_office.php">MS Office</a></li>
<li><a href="../../dienstleistung/schulung/mswindows/scb_windows.php">MS Windows</a></li>
<li><a href="../../dienstleistung/schulung/scb_internet/scb_internet.php">Internet</a></li>

</ul>
</li>
<li><a href="../../dienstleistung/support/scb_support.php">Support</a></li>
</ul>
</li>
<li><span><a href="../../location/scb_location.php">Wo wir sind</a></span></li>
<li><span><a href="../../Kontakt/scb_contact_us.php">Kontakt</a></span></li>
<li><span><a href="../../News/scb_news.php">News</a></span></li>
</ul>

so that some links are being rendered with an extra 'dienstleistung' in the path (being relative to the page that contains the include).

Try changing all the links that begin with: ../../ to just the single forward slash: / so that all links begin (are relative to) from the root directory.

i.e:

<ul class="level-0" id="cssmw">
<li><span><a href="/index.php">Home</a></span></li>
<li class="parent"><span><a href="#">Dienstleistungen</a></span>
<ul class="level-1">
<li><a href="/dienstleistung/projektmanagement/scb_pm.php">Projektmanagement</a></li>
<li class="parent"><a href="#">Schulung</a>
<ul class="level-2">
<li><a href="/dienstleistung/schulung/msoffice/scb_office.php">MS Office</a></li>
<li><a href="/dienstleistung/schulung/mswindows/scb_windows.php">MS Windows</a></li>
<li><a href="./dienstleistung/schulung/scb_internet/scb_internet.php">Internet</a></li>

</ul>
</li>
<li><a href="/dienstleistung/support/scb_support.php">Support</a></li>
</ul>
</li>
<li><span><a href="/location/scb_location.php">Wo wir sind</a></span></li>
<li><span><a href="/Kontakt/scb_contact_us.php">Kontakt</a></span></li>
<li><span><a href="/News/scb_news.php">News</a></span></li>
</ul>

As regards the space before the form, In your webassist/forms/fd_brassystucoba_default.css stylesheet (about line 62/63) add a float:left; property to the rule:

Edit: And change the width to 580px:

form.Brassystucoba_Default {
float:left;
width:580px;
}

Then in your webassist/forms/fd_brassystucoba_default.css stylesheet (about line 138), change:

width:614px;

to

width:580px;

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...