close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Inserting Products: Blank Page Issues

Thread began 8/24/2009 1:04 am by bludonda0356993 | Last modified 8/29/2009 12:37 pm by bludonda0356993 | 1634 views | 5 replies |

bludonda0356993

Inserting Products: Blank Page Issues

>>> SPECIAL EXPLANATORY NOTE FOR NEW VIEWERS OF THIS THREAD FROM THE ORIGINAL POSTER <<<<
//////////////////////////////////////////////////////////////////////////////////////

I have some harsh statements in the following threads for the Tech Support person who helped me which were entirely undeserved and I wish to apologize for making them. The problem I was dealing with was both simple and stupid and my fault (see entry dated for 08/29/09 @ 4:37 PM), and I would like to acknowledge Jason's time and patience in dealing with me offline to help me. I probably would not have seen my error if not for talking with him and reviewing my work a little closer.

I am not going to revise the following threads to sanitize my frustration with the situation at the time, I just want viewers to know and understand that these folks are doing an honest job of trying to get you answers to your problem.

Thanks.

////////////////////////////////////////////////////////////////////////////////////

I have searched the forum here and found partial descriptions of the issue I'm having but not quite what I'm going through at this point. Here's the deal:

After uploading to my host server, I&#8217;ve been trying to get things to work as described in the How-To documents, particularly &#8220;Setting up your PowerStore using the Admin back-end. Everything has gone fairly well up to this point, but when I got to the part about defining a new category, I would click the &#8220;Define&#8221; button and receive a blank page. There was nothing to see. I went back to the source page and looked for the code for the input and changed the following code:

<input type="button" onclick="document.WADAInsertForm.action='plugins/Products_Insert.php?defineBTN=true';document.WADAInsertForm.submit();" name="defineCategories" id="defineCategories" value="Define..." />

To this:

<input type="button" onclick="document.WADAInsertForm.action='plugins/productcategories_Insert.php?defineBTN=true';document.WADAInsertForm.submit();" name="defineCategories" id="defineCategories" value="Define..." />

Where the page referenced by the &#8216;onclick="document.WADAInsertForm.action&#8217; changed from the self referencing &#8216;Products_Insert.php&#8217; to the more obvious &#8216;productcategories_Insert.php&#8217;. This change allowed me to enter the categories I needed.

However, after adding all the other parameters for the product, when I click on the &#8220;Insert&#8221; button on the bottom of the page, I am again presented with another blank page. The browser back button returns me to the page and all the product info will be there but the image locations. Re-entering the image locations and clicking the cancel button brings up the &#8220;Product Results&#8221; page saying, &#8220;No results for your search&#8221;. Pressing the &#8220;Insert&#8221; button on this page has the same effect as the browser back button, bringing me back to the &#8220;Insert New Product For Sale&#8221; page.

I inserted some error tracking code as suggested in one of the other discussions here and now clicking the &#8220;Insert&#8221; button gives me quasi-helpful info stating either:

&#8220;Warning: Cannot modify header information - headers already sent by (output started at /homepages/37/d#########/htdocs/bellwetherwool-store/Connections/localhost.php:13) in /homepages/37/d#########/htdocs/bellwetherwool-store/WA_ValidationToolkit/WAVT_Scripts_PHP.php on line 71&#8221; ;

if no images were selected. Or if images are selected this longer version appears:

&#8220;Warning: move_uploaded_file(/roving_autumn.jpg) [function.move-uploaded-file]: failed to open stream: Permission denied in /homepages/37/d#########/htdocs/bellwetherwool-store/WA_DigitalFilePro/HelperPHP.php on line 173

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpGDzMVT' to '/roving_autumn.jpg' in /homepages/37/d#########/htdocs/bellwetherwool-store/WA_DigitalFilePro/HelperPHP.php on line 173

Warning: move_uploaded_file(/roving_autumn-1a.jpg) [function.move-uploaded-file]: failed to open stream: Permission denied in /homepages/37/d#########/htdocs/bellwetherwool-store/WA_DigitalFilePro/HelperPHP.php on line 173

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpjGhUy0' to '/roving_autumn-1a.jpg' in /homepages/37/d#########/htdocs/bellwetherwool-store/WA_DigitalFilePro/HelperPHP.php on line 173

Warning: Cannot modify header information - headers already sent by (output started at /homepages/37/d#########/htdocs/bellwetherwool-store/Connections/localhost.php:13) in /homepages/37/d#########/htdocs/bellwetherwool-store/WA_ValidationToolkit/WAVT_Scripts_PHP.php on line 71&#8221;.

From the issues I had with the "Define" button earlier in the form, I'm inclined to think that there is something similarly wrong with the code for the "Insert" input button at the end. Looking at it I see a lot of "if" arguments relating to validating the form fields in the "onclick" attribute, but nothing that tells it to do something or go somewhere like the "document.WADAInsertForm.action='plugins/productcategories_Insert.php" code in the onclick attribute in the "Define" button input tag.

So I&#8217;m sure I have done something wrong in my globals document or something, but at this point not being an Uber PHP programmer or anything I&#8217;m a bit frustrated at the amount of fiddling I have to do with this stuff to get this site to work. I have been trying to follow the How-to&#8217;s by the numbers - including signing up with 1&1 as my ISP &#8211; but often, I find that at critical junctures like this they completely leave me stranded! Not at all the quick and easy solution it was sold to me as.

Please, any help as to where I can go to fix this so I can get this site up and running as soon as possible. I would like to avoid any other similar issues as I go through trying to get this site to work, so if you can let me know where I'm going wrong on this process and where I should be looking for other possible issues, I'd really appreciate it.

It&#8217;s late and I&#8217;m very tired and my client and I are getting anxious to have this work without too much more hassle.

Thanks.

Sign in to reply to this post

Jason ByrnesWebAssist

The forms action should not be changed.

The product categories_Insert.php page is not configured to handle inserting product information in the database. It is only for adding Product Categories.


the first error:
&#8220;Warning: Cannot modify header information - headers already sent by (output started at /homepages/37/d#########/htdocs/bellwetherwool-store/Connections/localhost.php:13) in /homepages/37/d#########/htdocs/bellwetherwool-store/WA_ValidationToolkit/WAVT_Scripts_PHP.php on line 71&#8221; ;


is occurring in the localhost.php File around Line 13. most likely there are blank lines after the "?>" at line 10. remove any blank lines after the closing PHP tag "?>".



the other errors:
Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpGDzMVT' to '/roving_autumn.jpg' in /homepages/37/d#########/htdocs/bellwetherwool-store/WA_DigitalFilePro/HelperPHP.php on line 173


mean that the image upload location does not have the needed permissions.

judging by the error, the images are being uploaded to the site root at:
/homepages/37/d#########/htdocs/

you will need to make sure the htdocs/ folder has a minimum of 766


the following FAQ on 1and1: 1and1 , explains how to change folder permissions:
5.html

Sign in to reply to this post

bludonda0356993

Insert Product Blank Pages: more detail please

Thanks for the reply Jason.

Yes, I agree. I should not have change ANYTHING on that page to make it work in the first place. It's not my job. It's what I paid YOU guys to do when I ordered the product. I should just have to follow the easy-to-use How-To instructions, tweak the Globals file and life would be beautiful, right? I don't recall reading in the How-To's that I had ANYTHING to do in the localhost.php page nor folder permissions on the ISP end, or even what the heck making "sure the htdocs/ folder has a minimum of 766" means, in getting this product to work as advertised.

>>>>| UPDATE |<<<<

Found and removed suspect extra spaces and lines in localhost.php file.
Uploaded file to external server.

>>>>>>>| END |<<<<<<<


But chastising me for taking initiative doesn't explain why was I getting a blank page when I tried to define a category in the first place (yet making a change did). It would be much more helpful if you could offer some explanation as to where I went wrong in the first place.

Let's assume that I had followed EVERYTHING in the How-To instructions by the letter (and I tried very hard to and I'm pretty sure I did), what could possibly cause that sort of behavior and how would I fix it? Now THAT would be helpful.

I can replace the page's original code, since I only changed that one part of the attribute and run it again with the error code in page and see what happens. Would that be helpful?

>>>>>>>| UPDATE |<<<<<<<

Replaced original onclick code for Define button on Insert New Product form page.
Uploaded page to external server.
Tested page and define page now appears to work as intended.
Thanks.

>>>>>>>| END |<<<<<<<

Should I just go to 1&1 fix the directories permission issue? Would that fix the blank page issue so I can continue or only the image upload problem? You have the error information that gives you a directory structure on the ISP server. Is this directory structure correct? Should it look different had I done the process right to get the product to behave as specified? What would/SHOULD I change to make it correct? Is it supposed to be going through the localhost.php file on the ISP server? What do I tweak to make this work?

>>>>>>>| UPDATE |<<<<<<<<

Read instructions on changing permissions for directories on 1&1 and checked permissions for the folders I have access to which is the powerstore folder.
Permissions seem to be fine but changed the main store folder to 766 anyway, which gave me a 403 error after trying to insert a new product again.
Changed the permissions back to their default 755 and tried insert form again but received the "permission denied" errors from the error script on the page.
The images are already on the external server. Why do I need to upload them again? Am I trying to upload to the database?

My original questions above about the directory structure are still valid. Can you tell from that if I've got something configured wrong on my end?

Thanks.

>>>>>>>| END |<<<<<<<<

I'm really sorry to be such a pain, but really, I have been trying hard to get this to work as I hoped it would and as it was advertised and your last answers aren't getting me up to speed.

I'm done venting for now. I'll go tweak the localhost.php page (if I can find it) and try to reset the folders permission on the uploading folders.

I'll report back if I have any success or not.

Thanks.

>>>>>>>>| UPDATE |<<<<<<<

I noticed several other image upload issues in the forum here. I'll check those for answers while I'm waiting for a response to this post.

>>>>>>>>| END |<<<<<<<<

Sign in to reply to this post

Jason ByrnesWebAssist

I will need to look into these problems with you. I have created a support ticket for you. To view and edit your support ticket, please log into your support history at the following URL:
supporthistory.php

Sign in to reply to this post

bludonda0356993

Insert Product Blank Pages: Hosting provider response

After checking the other similar threads, it seemed that there was some sort of file or folder permission that needed to be set, so I contacted my hosting provider (1&1) and asked where this temp file or folder could be so I could arrange to have permissions set to receive the uploaded images. Unfortunately, the ultimate conclusion was they had NO IDEA where such a folder or file might be on their servers. They suggested I get in touch with you to find out where the problem is.

So what to do now? I have responded to the tech support ticket and am waiting for some reply there or here to resolve this issue.

My client wondered why I didn't use this kind of thing to solve my problem earlier, but the nearly 24 hour delay in responses is very large factor in not using this forum to find answers to my problems here.

Hopefully, we'll find a solution soon.

Thanks.

Sign in to reply to this post

bludonda0356993

Insert Product Blank Pages: The Case of the lower case

First off, if you have gotten this far into this particular thread, then let me say that Jason here has done a great job offline to help me. I wish to apologize for being so harsh earlier at the start. I always like a to eat a little crow with my humble pie. Sorry Jason and thanks for your time in trying to help me.

Anyway, Jason and I went over several possible causes for my problem and most worked but others didn't. However, to make a long story short, ultimately the fault was mine. I had made a copy of the image folder and did not realize that the original image folder was created with a CAPITAL "I" and mine was a lower case "i" (my standard, by-habit naming convention). Also, I had neglected to copy over the "Upload" folder for the images to go into.

After I noticed that small but critical situation and fixed it, and after some red herrings in setting folder/directory permissions on the host server and speculation about the .htaccess file settings, I set everything back to the default and was able to finally start adding products and images to the site.

There is still some question about the access settings being correct, but the thing is working now so I'm not going to mess with it too much.

The bottom line is, don't muck about in the files or directories more than what they instruct you. If you do, be prepared for the frustrating consequences as you go back and inspect any changes or renames you did in the process that could affect the function of your site as intended. All of my issues turned out to be caused by my messing with code I should have left alone or a simple (and stupid on my part) matter of a lower case "i" in a directory/folder name rather than a capital "I". That and a critical folder that did not get copied over caused me countless hours of frustration.

In my "real job" I deal with maintaining a state agency website and I thought I had it pretty well figured out, but we don't do a lot of PHP back end stuff like this and I took it for granted I could figure it out. I was too clever by half and it made way more work for myself than was needed.

I suspect if we just follow the directions as stated here would be a lot less issues posted on these forums. I just want to give folks a heads up on what the real problem with my issue was.

But I still have a lot of work to do before this site is fully functional as intended, but I'm feeling a bit more confident that I'll be able to get things sorted out. I'm sure I'll also be checking back here for more answers.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...