close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

CSS Formbuilder2 has multiple problems

Thread began 2/09/2012 6:52 pm by ernietamminga142573 | Last modified 2/16/2012 1:18 pm by Jason Byrnes | 1467 views | 11 replies |

ernietamminga142573

CSS Formbuilder2.01 displays error messages in form that has no errors

I have installed CSS FormBuilder2 and created a simple "Contact" form on a simple php page.

First, a quick complaint about the lack of documentation... the "How to" materials for FormBuilder don't mention that you have to upload the folder "webassist" to the server. After receiving a bunch of error messages when using the form, I finally figured that out for myself. I uploaded the folder and tried again to fill out the form. The following problems occurred:

(1)The ERROR MESSAGE for every field in the form is displayed next to the field, as soon as the form is displayed. I'm SURE that that is wrong.
(2)I had added one checkbox-field to the form, and gave it my own caption. But the caption "Please agree to our terms" appears next to the checkbox, in addition to the caption I specified. I did NOT specify the "terms" message. Where does it come from???
(3)I filled in the form and clicked the Submit button. It apparently "worked", but there was no confirmation of any kind. A website visitor would seem to have no way of knowing whether or not the form was accepted.
(4)In the email that was generated and sent to the address that I had specified, there's a whole two paragraphs of "Lorem ipsum" stuff in a field labeled "Additional Notes". I certainly didn't specify that!!
(5)Again as a user, I deliberatly mis-entered the Captcha code. The error message turned red (it had already been there, in black, as mentioned above), and then I re-entered the Captcha code correctly. That resulted in the error messages shown below...

Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/stillpoi/public_html/contactus.php on line 28

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/stillpoi/public_html/contactus.php:28) in /home/stillpoi/public_html/contactus.php on line 76

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/stillpoi/public_html/contactus.php:28) in /home/stillpoi/public_html/contactus.php on line 76

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/stillpoi/public_html/contactus.php:28) in /home/stillpoi/public_html/webassist/email/mail_php.php on line 274

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/stillpoi/public_html/contactus.php:28) in /home/stillpoi/public_html/webassist/email/mail_php.php on line 274

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/stillpoi/public_html/contactus.php:28) in /home/stillpoi/public_html/contactus.php on line 106

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/stillpoi/public_html/contactus.php:28) in /home/stillpoi/public_html/contactus.php on line 106
====================
This is no fun at all...

Sign in to reply to this post

Jason ByrnesWebAssist

1) Make sure that the SpryAssets folder is also uploaded to the server.

2) Send a link to your page and attach a copy in a zip archive and I can give more info on why the agree to the terms message is there and how to remove it.

3) Go to the Server Behaviors panel (Window -> Server Behaviors), and double click the Universal Email server behavior to edit it and set a Go To page, this will set Universal Email to redirect to a confirmation page after the email is sent.

4) Universal Email creates a template file for the email message in the webassist/email/templates folder. the Lorem ipsum text is place holder content included in the default template, you can edit the template file to remove it.

5) The error messages you are seeing are because the host has safe m ode turned on the php.ini file. Universal Email cannot work correctly on servers where safe mode is enabled.

Sign in to reply to this post

ernietamminga142573

Web provider says safe_mode is "off", FormBuilder form thinks it's "on"

Thank you for the reply.
I have now uploaded the Spry Assets folder, and I have modified the Universal Email server behavior, as you suggested.
I then created a new Contact form --- using the simplest possible version, with no added fields (not even the "checkbox" field I eventually want to add).
Now when I access the form on my website, the first of my original problems seems to have gone away -- the field-specific ERROR MESSAGES are no longer showing up on the form when the form first appears.
However, when I fill-in the form and SUBMIT it, I'm still getting the error messages that start with this one:
-----------
Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/stillpoi/public_html/testform.php on line 28
----------
The Tech Support folks at my hosting-service-provider assure me that safe_mode is OFF. I had asked them if turning off safe_mode in my "main" reseller account would also automatically mean that it's off for my client domains. Their response was this:
------------
Safe_mode is already off for the accounts( under your reseller), please let us know if you need any further assistance.
------------
Indeed, if I run "phpinfo" on my main domain, it does say safe_mode is off:

safe_mode Off Off

safe_mode_exec_dir /usr/local/php/bin /usr/local/php/bin
safe_mode_gid Off Off
safe_mode_include_dir no value no value
(and a few lines later...)
sql.safe_mode Off Off

For whatever reason, it seems that my WebAssist-generated form thinks that safe_mode is ON, when it's actually OFF. Do you know why that can be??

Sign in to reply to this post

Jason ByrnesWebAssist

"For whatever reason, it seems that my WebAssist-generated form thinks that safe_mode is ON"


the reality is that the error:
Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /home/stillpoi/public_html/testform.php on line 28



is not a webassist error, it is generated by the PHP server. it is being caused by the following code on your page:
set_time_limit(0);

which we use to over ride the server time limit setting. It may be that the server have disabled this setting, but the php server itself is reporting that it cannot be changed because safe mode is turned on.

I'm not trying to argue whether safe mode is on or not, just trying to illustrate that it is the php server saying safe mode is on in the error message, the error message text is not generated by webassist code, but by the php server. for some reason, the php server is reporting that the time limit function is disabled because the server has safe mode enabled.


one way to get around the error is to comment that line of code, change:
set_time_limit(0);


to:
//set_time_limit(0);

Sign in to reply to this post

ernietamminga142573

TWO copies of email sent after form is submitted

Thank you.
I've made a lot of progress now -- tech support at my hosting server also fixed the safe_mode problem.
I have one remaining problem:
When I designate the email TEMPLATE I want to be used for sending the notification & form contents to me, it ignores the one I specify, and uses the default "lorem ipsum" one instead. (I did make sure to upload my customized one.)
As a workaround-attempt, I uploaded a customized copy of the template called "templates.php", with the same customizations I made in my desired template.

Now hen I fill-in and submit a form, I get TWO notification messages, which both include the contents of the filled-in form, instead of just one. One of the messages uses the format I uploaded as "templates.php", and the other one uses the default "lorem ipsum" one.
How do I "turn off" the sending of the redundant notification message so that I receive only one?

I'm a bit mystified about how Universal EMail uses (or doesn't use) the email template files.

Sign in to reply to this post

Jason ByrnesWebAssist

send a copy of the page and the webassist/email folder please.

Sign in to reply to this post

ernietamminga142573

Here they are...

Attached Files
email.zip
testform3.zip
Sign in to reply to this post

Jason ByrnesWebAssist

there are 2 universal email behaviors on the page.

the first on at lines 24 - 112, is connected to the webassist/email/templates/templates.php template file.

the second on at lines 113 - 201 is connected to the webassist/email/templates/Blank_10.ph template file

Sign in to reply to this post

ernietamminga142573

"From" is missing in generated EMail - other than that, SUCCESS!!

I'm VERY, VERY CLOSE to being "there".
The only thing lacking now is that Universal EMail ignores whatever I put in the "from" field -- the "sender" that I want to appear in the generated EMail message.
(I'm trying to use a constant, not a database field.)

"OVERALL" COMMENT ---
I'm realizing from our dialog that to really use FormBuilder effectively, one needs to know how to code php. I'm not a php coder and would very much prefer not to become one. The video-demo of FormBuilder on the WebAssist website gave me the impression that the visual interface would handle everything. Not really the case -- but anyway, with your help I've finally got *almost* 100% of what I've been trying to do.
I'm going to document, for myself, all the extra steps that are involved in implementing a form and emailing its contents to an administrator, beyond what you can do with just the visual interface. Gonna go do that quick now, before I forget some of the steps...
I'll be happy to share the resulting document, if anyone else might find it useful. (In my previous life, I was in charge of the technical-documentation group at a telecommunications software company.)

Sign in to reply to this post

Jason ByrnesWebAssist

in the files you have sent me, it looks like you have set the from address in universal email to use:
Stillpoint Website

go to the server behaviors panel, double click universal email, click the lightning bolt next to the from address and select the EmailAddress form element.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...