close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Dynamic Menu Problem

Thread began 6/24/2009 5:35 pm by gpac357497 | Last modified 9/03/2009 8:20 pm by simmo515303621 | 4906 views | 22 replies |

gpac357497

Dynamic Menu Problem

Using CS3 build 9.0 and latest Menu Writer 2.0.1

The dynamic menu is displaying the label but the appended URL variable "?LineID=[lineId]" is not being parsed in the URL.

treexml.xml shows the correct URL:

<mm:treenode value="*line -> lineName|/MasterPages/LineDetail/LineDetail.php?LineID=[lineId]"

But menu.php does not. It also confirms why I do not see the URL variable:

<li class="parent"><a href="<?php echo($assumedRoot); ?>MasterPages/LineDetail/LineDetail.php"><?php echo $row_menuwriter_line["lineName"]; ?></a>
<?php

I have checked the time stamp of all the cssmw files and they agree with the time of edit.
I have completely removed the menu and started from scratch to no avail.
I have uninstalled menu writer and reinstalled (2.0.1) to no avail.
I have submitted a support ticket, got one response and thereafter abandoned.

Has anyone had any experience with this or can help?

Gary

Sign in to reply to this post

xag

I was having the same problem but all I did was take out <?php echo($assumedRoot); ?> and manually typed in what I needed... Just a word of caution though. When ever I manually edit the menu.php page and tried to change links in the gui it broke things. Now I have to manually edit the menu.php to see the changes in links. But the design part still worked with the gui.

Sign in to reply to this post

gpac357497

Thanks for the feedback. At least I now know that it's not just something I am doing.

I also got it working by manually editing menu.php but as you say as soon as you even touch something in the GUI you have to redo the manual edits. I have also found some grundgy positioning problems where the code doesn't track the GUI.

At the peak of my frustration however is the complete disinterest of the technical support department about the problem. This is something finite, repeatable and just plain not doing what it is supposed to do.

I still wait for the attention of technical support.

Sign in to reply to this post

xag

ya it took me a long time to get the positioning right. Even to shrink the menu and get the 2nd and 3rd level to line up right and look good on my page took me a while. I finally just went in the CSS part and just did it by hand. Don't care to use the interface much more. I would do the menu's myself but this still saves me time on hand coding everything and making the images and what not. haha and don't hold your breath about the tech support... There must be something going on there because they are taking forever. My ticket took 2 weeks until they finally said 'we can't replicate it and need to give you a call'. maybe they are just swamped and finally need to hire more engineers lol ...Just trying to stimulate the economy every lil way I can.

Sign in to reply to this post

Ray BorduinWebAssist

It sounds like a bug to me. It should retain the url parameters.

The <?php echo($assumedRoot); ?> stores two values so that you can have a different structure on your testing server and don't need to update the menu to go live.

You can remove it by hand, but I don't think that has anything to do with the problem reported.

Not retaining URL parameters is a bug if it happens. Support is pretty responsive and that is the best route to getting bugs looked into and resolved by an engineer. It can take longer if the problem is a bug or is unreproduceable simply because those things take more time to look into.

Sign in to reply to this post

xag

Why Good Morning to you Ray! In the office extra early today huh? I usually don't expect you in until 10am est ;-)... Well should we post an incident or actually gpac357497 want to take the lead and get help with your problem from tech support.

Sign in to reply to this post

Ray BorduinWebAssist

If a support incident is opened that is the most important thing. It will go to support from there if they are able to reproduce it they will either respond with a work around if they can find one, or forward it to an engineer. Even then there may be no quick fix, so you may not get one.

It is when it is a bug that support can't fix directly that it can stay in support longer... maybe even a week or two if it requires engineering time, QA, and other attention to address.

In this case there will probably be no quick resolution since it appears to be a bug in the tool that has a work around... it won't get a high engineering priority. However it will be addressed in time once reported... everything is.

By submitting a support incident you will at least ensure that it will be fixed in the next dot release and the more issues are reported the faster that dot release will be created.

Sign in to reply to this post

gpac357497

A support engineer wants to call me on this because he can't repeat the problem on his computer. This won't happen now until next week. I will post the result.

But Ray this is hardly a bug with a workaround. In my case that is saying that the workaround is hand coding. Why did I buy the tool in the first place?

None the less, maybe it's a quirky thing to do with my particular installation. I'll wait 'till next week.

Sign in to reply to this post

gpac357497

Update

The day that I advised tech support to call came but no call or message from tech support.
Interesting?

Sign in to reply to this post

xag

ya well at least you didn't have to wait 2 weeks and was given another tech engineer! I got Jimmy Wu and he is suppose to call me tonight but his real quick to answer my log post so it should be ok. I'm about to start calling and asking for specific engineers! lol But hey its free right? I remember when I first got Web Assist they only gave me 3 support calls for a whole suit so I can't complain to much.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...