close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Use of quote causes garbled content

Thread began 3/05/2010 1:38 pm by Stan.Shaw269802 | Last modified 3/10/2010 7:56 pm by Jason Byrnes | 1146 views | 9 replies |

Stan.Shaw269802

Use of quote causes garbled content

You can view the page: about_us.php and can see the text "Haluch’s Landscapes" when the actual text displayed in the PowerCMS panel is "Haluch’s Landscapes"

So it seems there is an issue when a quote is used as can be seen elsewhere on the same page. What is the resolution to this?

Sign in to reply to this post

Jason ByrnesWebAssist

I'm not able to reproduce this with my install of powerCMS.

It could be the database Encoding or collation being used on your MySQL server, you can try changing the collation to latin_swedish_ci and set the encoding to cp1252 west European

Sign in to reply to this post

Stan.Shaw269802

Originally Said By: Jason Byrnes
  I'm not able to reproduce this with my install of powerCMS.

It could be the database Encoding or collation being used on your MySQL server, you can try changing the collation to latin_swedish_ci and set the encoding to cp1252 west European  



Really? I guess I would need to research these options, but why would I choose something other than english?

Sign in to reply to this post

anonymous

Stan,

latin1 or latin_swedish is typically the default encoding for MySQL and is what typically works best.

It has nothing to do with the language the content is in - this is simply a recognition of character sets for collation purposes. latin_swedish was always the default as MySQL was originally created in Sweden by a Finn (Ulf Michael Widenius) along with some Swedes. So it's worth a check... but your database probably already uses the default collation.

And just for some real geeky knowledge, Widenius has a daughter named "My" and son named "Max". hence the names MySQL and the MaxDB.

The other question I would have... you didn't by chance copy and paste that into your content, did you? I know sometimes clients will send their copy over on a word document and want me to copy and paste it in and I can confirm that copy and pasting can make WYSIWYG editors go crazy in what they output. You may need to check the source on your HTMLEditor instance and remove all the formatting.



Best regards,

Brian

Sign in to reply to this post

neilo

Cheers Brian,

Always a bonus to learn new stuff, geeky or not! I imagine the third child must have resented being named phpMy when the Admin side of things was addressed.

Sign in to reply to this post

Stan.Shaw269802

I find I have in my.ini (I am presuming this is the correct ini, as it is the only one that appears to ever have been updated).:
default-character-set=latin1

I don't find an encoding specification.. Nor can I find a reference to it, Any directions you can provide? I am running MySQL 5.1.34

To change an encoding setting, do I need to export everything in the database first?

Sign in to reply to this post

Stan.Shaw269802

Originally Said By: SOJO web
  The other question I would have... you didn't by chance copy and paste that into your content, did you? I know sometimes clients will send their copy over on a word document and want me to copy and paste it in and I can confirm that copy and pasting can make WYSIWYG editors go crazy in what they output. You may need to check the source on your HTMLEditor instance and remove all the formatting.
Best regards,
Brian  



Yes, I did cut and paste, but the code came from Dreamweaver where I developed the page, and when I pasted I was in "source" mode of CMS. I am anticipating this is a full html mode, so what I see is what is really there, correct?

Sign in to reply to this post

Jason ByrnesWebAssist

how you change the encoding or collation depends on the tool you use to manage your mySQL database. I am including a screen shot showing how to change those settings using SequalPro.


another thing to check is the data in the tabel directly. Does the apostrophe apear correct in the database?

Sign in to reply to this post

Stan.Shaw269802

I found the problem, we had used a "special" quote, not the standard keyboard quotes. As this was originally coded in Dreamweaver, ’ was used, but of course in the content it shows as ’

PowerCMS does not work with such characters, clearly, but wants ' used instead.

Thank all for their suggestions.

Sign in to reply to this post

Jason ByrnesWebAssist

Great, glad to hear you found the problem.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...