close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

SecurityAssist 1.1.9 Beta Available

Thread began 1/12/2010 6:33 pm by Anna Robinson | Last modified 3/21/2010 6:03 pm by Ray Borduin | 2813 views | 11 replies |

Anna Robinson

SecurityAssist 1.1.9 Beta Available

A beta build for SecurityAssist 1.1.9 is now available. Log in and visit the Download Center; click on SecurityAssist, then the Beta Builds section of the page.

This build fixes bugs that:
- caused all binding formatting options to be lost when the SHA1 format option was added after installing SecurityAssist Version 1.1.7.
- prevented all groups from displaying in the Access Groups Manager when the total amount of groups exceeded 10.
- caused a PHP error to occur after loading any SecurityAssist page when $_SERVER["HTTPS"] was disabled in the PHP server installation.
- caused a variety of JavaScript errors to occur in Dreamweaver when using SecurityAssist on a PowerPC running OSX.

------------------------------------

As quality assurance is not fully complete on beta builds, technical support cannot be provided. However, if you experience issues with this beta build, please report the issue in this forum. We appreciate all the feedback we can get on beta builds. This will allow us to strengthen the next stable dot release. The last stable build will remain in the Download Center and you can always revert to it should you experience problems with the beta.

Sign in to reply to this post

tom113673

Beta install failure

I removed the previous versions of Security Assist and Data Assist (in order to install the beta). I then tried to install the SA beta update: "Can't update menus. The extension will not be installed". I decided to revert to the previous version - same error message. The Data Assist update however installed fine after this.

I have read that menus.xml can cause problems; I think the solution is to reinstall everything (and waste a lot of time). Given that I can install Data Assist without problems, it seems likely that the Security Assist beta is the problem. I would appreciate any suggestions. Eg could the installer have made changes to menus.xml which could be manually removed? (I have deleted the wincache file - I do this several times a day.)

Thanks,
Tom

Sign in to reply to this post

Eric Mittman

I think you should try renaming the configuration and re-installing to see if it clears this up for you. Here is a link to a post with steps you can take to rename the configuration folder and undo any corruption that may have occurred in there.

showpost.php?p=12293&postcount=2

Please give this a try and let us know if the issue persists. If so I will open a ticket for you on this issue so that it can be looked into further.

Sign in to reply to this post

tom113673

>I think you should try renaming the configuration and re-installing to see if it clears this up for you.<

Thank you for your suggestion. As I mentioned I wanted to avoid this if possible as it can be time-consuming and wondered if there was any change which installing the extension might have made which I could undo manually (eg editing menus.xml). As it happens I came across a post on another forum which suggested deleting another configuration file:
C:\Users\username\AppData\Roaming\Adobe\Dreamweaver CS4\en_US\Configuration\ServerFormats\PHP_MySQL\Formats.xml
Surprisingly this did the trick and I could then reinstall the previous version of SecurityAssist. Installing the beta version seemed to cause the problem but it was possibly coincidence - I didn't want to risk it anyway.

I expect reinstalling everything is the only solution in some cases but if you take a cautious approach it can take a very long time to install WA extensions. I think some have suggested it's alright to click 'Yes to All' to the install dialog but given this is likely to mean overwriting new js files with older versions, I am not confident with this approach. Unless you think this cannot cause problems, would it possible for WA to provide a list in the WA extension download section, indicating in which order the extensions should be installed (presumably by release date)? I would have thought this would be very helpful and make re-installing a great deal easier (and less likely to cause hand injuries). Do you not think this would be useful and reduce javascript error issues etc.? I expect you have such a list.

Tom

Sign in to reply to this post

Eric Mittman

I'm glad that you were able to resolve this without having to redo the entire config.

I think you have some valid points but we have always suggested clicking on the yes to all button. The way the message is worded makes it seem like you would be overwriting existing files with older versions but this is not the case. These are files that should have different dates but you should not worry about overwriting them. Choosing 'yes to all' is the correct option.

As far as an order of product installation we do not have a list for this, like you noted you should try installing the latest extensions last, but the order should not make a difference. I have brought this up with the managers to ensure that they see the feedback.

Sign in to reply to this post

tom113673

>The way the message is worded makes it seem like you would be overwriting existing files with older versions but this is not the case.<

The message and button text make it clear that you will be overwriting files, whether newer, older or of the same date. Many people have complained about this. If this is not the case this is good news.

Thanks for your help again.

Sign in to reply to this post

Office Guy-172461

If you look at the files that are "newer", you will see that they are images and other support files that do not change. In the case of these type of files, the creation date doesn't matter. I've been overwriting these files for a long time without any problems.

It is unfortunate that Adobe refuses to fix Extension Manager and include an "Overwrite all Older" option to give people some peace of mind. It is very tedious to review every single file. Fortunately using the "Overwrite All" works fine for WA extensions.

Sign in to reply to this post

tom113673

>If you look at the files that are "newer", you will see that they are images and other support files that do not change.<

I know many of them are image files but there are also .js files. I experimented by saving some new Javascript files before choosing to overwrite them - the new and old were indeed identical (not that I made an extensive test).

Thanks again for confirming this is not a problem with WA extensions.

Sign in to reply to this post

toms016390756

nice job guys

Sign in to reply to this post

info148906

Sha1 crashing problem

Hi Support,

I have been having problems with CS4 crashing when applying sha1 to the database field, using security assist.

I updated to security assist 1.1.9 (1.1.8 802) - didnt fix it
Rebuilt the configuration folder (which took 2 hours) - didnt fix it

Any other ideas ?!?!?!

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...