close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

DataAssist - problem with results page

Thread began 12/08/2009 10:23 am by ant.knott394719 | Last modified 12/18/2009 3:53 pm by Eric Mittman | 1780 views | 10 replies |

ant.knott394719

DataAssist - problem with results page

I am trying to create a product catalogue in dataassist that has at least 3 columns, i usually select 2 rows and 4 columns but i can't get this to work. If i choose one column with any number of rows, it works fine but when i select 2 columns or more i get error messages. The message says 'you have made changes to code that is not marked as editable - if you retain these changes they will be lost the next time you apply a template update to this file - do you want to retain the changes until then?

This is usually followed by a javascript error message 'while executing a server behaviour in Wada_8Repeat Selection.htm - a javascript error occured. I thought it might be caused by the width being too short so i deleted all the files increased the width of my page design from 860px to 1050px, went through site assist again and then datassist but it made no difference, i'm still getting the same error. i must have run the wizard about 50 times now, so i could do with some help, any ideas, i couldn't see a similar problem in the forums, only the standard appbullder js error?

Sign in to reply to this post

neilo

It's odd that you can make it work fine by selecting one column, but not two.

The "you have made changes to code that is not marked as editable" message is telling you that you are trying to make changes to an area of your page which has not been marked as editable in your template.

Have you tried opening your template and making a larger region editable? If it comes to it, you could make the whole content area editable while you apply your repeat regions, and return the template to how it was once you've done that.

Sign in to reply to this post

ant.knott394719

soothing

ok i went into the siteassist_template.dwt file created by siteassist to see if i could make the outerwrapper or entire content editable but i'm obviously doing something wrong as it comes up with the message 'the selection already contains or overlaps with an editable or repeating region'. Do i need to go back into css sculptor or site assist and make changes there or do i need to do something else in dreamweaver?

When i opened the template in dreamweaver there was a tiny boxy area on the left marked content so i clicked inside and pressed space to create a paragraph which increased the size of the green box width but it made no difference when running the wizard again. Any suggestions would be gratefully received.

Sign in to reply to this post

neilo

Hi ant,

The template created by CSS Sculptor should have created the correct template. There is probably some better advice from one of the WA Guys.

But if you want to test to see if the template is causing the problem without altering the original template, then back up the page you are having a problem with (in case you need to revert to it later on), and with your 'problem page' open, from the Dreamweaver menu select:

Modify > Templates > 'Detach from Template'

This will allow editing on the page. Try your repeat region now, and see if it works.

Sign in to reply to this post

Jason ByrnesWebAssist

See the following thread for information on the "you have made changes to code that is not marked as editable" error message:
showthread.php?t=5574




for the javascript error, try deleting the Dreamweaver Cache file from the users configuration folder:
common_installation_issues.pdf

Sign in to reply to this post

ant.knott394719

dataassist not assisting with product columns

Still having trouble with dataassist wizard not allowing me to have more than one
column for my product page, i've tried everything, different container widths, detaching template, creating a seperate template, different regions, margins and padding, removing .dat file, even tried using a fresh un-customized sculptor template but nothing works. The only thing i can do now is try reinstalling dataassist to see if there is problem with the program itself, unless you have any other ideas, failing that i will have to try to work out how to create the page that the wizard is meant to produce manually but this is a daunting prospect, the WA interactive tutorial only shows you how to do one column which i managed to do ok but it doesn't tell you how to create extra columns for the data to flow onto or how to add the other bits and bobs like the forward and backward symbols etc. I'd prefer to get the wizard to work if i can but i'm not very optimistic. I'm surprised to see no one else is having the same problem as me. Perhaps it is a mac with snowleapord and cs4 issue, i don't know? i'll let you know how i get on.

Sign in to reply to this post

Eric Mittman

You mentioned that the original issue you were experiencing was the issue with the template and not being able to edit it because of the error you were getting. Is this still the case? If so have you tried the suggestion about detaching the page from the template first? Please post back and let us know some more about what you are currently experiencing with this, also if you could include some screen shots that might be helpful as well. As far as compatibility the environment you described is the same as ones we are testing on so this should not be the issue.

Sign in to reply to this post

ant.knott394719

Dataassist wizard - error message

I actually don't want to edit the template, i just want to run the dataassist wizard, i want to be able to choose PUBLIC and then select 3 Rows and 3 Columns (or 4 columns) but after going through the wizard options, i always get an error message. When the message asks 'do i want to retain the changes until then' i usually select no, if i select yes, i end up with a blank screen when i go to view it in the browser. If i select the item 'repeat selection' in the server behaviours list i get an error message and the whole thing crashes. The error message reads:

'while executing onLoaad in WADA Repeat Selection.htm, the following javascript error occurred: At line 166 of file 'macintosh HD: Applications: Adobe: Adobe Dreamweaver CS4: Configuration: Commands: WADA Repeat Selection.js" gSSREC.sbParticipants [2] has no properties'

I therefore tend to delete this server behaviour after running the wizard, i then choose modify and detatch from template, if i don't detatch and i try to add the repeat selection server behavior again, i get the original error message about trying to make changes to code that is not marked as editable.

After detaching from template i select the div 'tableWADAresults table' which includes the default image and data underneath, i then click on the plus sign and select dataassist and repeat selection. In the box that appears i chose the only dynamic option available 'WADAitems' and 3 for the amount but this doesn't do anything as i'm still left with one column when i test. The column has 9 images going vertically down the page but i would like 3 and 3 and 3 going horizontally.

The other thing i tried was detaching from template before running the wizard, then making it a template again and selecting my own region, i tried this twice, once using the content region and once using content wrapper for my region but this also failed.

I'll send some screen shots for you the next time i run the wizard so you can see whats happening.

One thing i recently noticed (which may or may not have something to do with the problem) if i click on live view which i haven't been using, i tend to preview in safari browser but if i click on live view, i see a load of code sitting in the topnavigation area where the menu should be and the menu is pushed down below it. This doesn't appear when i preview in the browser but maybe there is problem with the 'menuwriter' design, i don't know. I don't think so because i've tried running the wizard using an un-customised template and menu and that also errored.

regards
Ant

Sign in to reply to this post

Eric Mittman

Have you tried running the wizard without selecting a page derived from a template or a template to style the pages with? You should be able to run the wizard without using any template or template derived pags, then after the fact you can attach the template. What is happening for you when you attempt to add the template to the page after the fact?

As for the js error you are getting when clicking on the repeat region have you tried deleting your cache file or renaming your configuration folder? If not please try the steps listed here in this link for deleting the cache file:

146/

If deleting the cache file does not fix the problem for you try renaming the config folder to see if this resolves the issue. Please get back to us with the result and the additional details about this.

Sign in to reply to this post

ant.knott394719

success

yes, adding the template after the wizard works perfectly, thanks for your help.
i didn't try renaming the cache file as i was worried about losing my presets but probably don't need to do this now. thanks again. Ant

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...