close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

delete multiple records

Thread began 10/03/2009 3:49 am by simmo515303621 | Last modified 10/14/2009 4:01 pm by Eric Mittman | 1931 views | 11 replies |

simmo515303621

delete multiple records

Hello,

I have followed the sample videos but multiple delete never seems to work... I have tried using the DM repaet region, and also DA repeat region

I have been working wiht a test as - also I want to know how to apply the delete multiple records to an existing DA Results page.

When I tried I recived a very strange issue where I could not see any thing in DW but I could when uploaded...

I have attached the tets page I am testing with.

Attached Files
test.txt
Sign in to reply to this post

Eric Mittman

I have performed some testing on this and have looked over your page. I think the problem may be the way you have incorporated your submit button into the repeat selection. If you have the button outside of the repeat selection I think it may work for you. Other than this it seems like your page is nearly identical to mine.

Sign in to reply to this post

simmo515303621

Originally Said By: Eric Mittman
  I have performed some testing on this and have looked over your page. I think the problem may be the way you have incorporated your submit button into the repeat selection. If you have the button outside of the repeat selection I think it may work for you. Other than this it seems like your page is nearly identical to mine.  




When I initially set up the repeat region the button is out side the repeat region... after applying delete multiple it appears with in.... Can you please provide me with an updates version on my page that works, so I can compare and fix the issue.

Thanks

Sign in to reply to this post

Eric Mittman

The reason your button was included in the repeat selection may have to do with how you applied it. In my test I just highlighted the input field and the check box only then applied the repeat selection.

I have moved your submit button outside of the loop and updated the name and id to be just delete like your server behavior is looking for.

Attached Files
delete.zip
Sign in to reply to this post

simmo515303621

Originally Said By: Eric Mittman
  The reason your button was included in the repeat selection may have to do with how you applied it. In my test I just highlighted the input field and the check box only then applied the repeat selection.

I have moved your submit button outside of the loop and updated the name and id to be just delete like your server behavior is looking for.  




Ok after messing around I got it to work, but it does not work as intended modification is required for even a basic multiple delete or insert.

Now I would like to add this function to an already existing Results page... It is again not working for me...

Attached Files
results.zip
Sign in to reply to this post

Eric Mittman

What is the result you are getting on the current page? Looking at the code it seems that you may have too many repeat selections applied to the page. What were your steps for implementing? If you are adding this form info into a repeat region and then adding in the repeat selection this could be a part of the problem. You should be either just displaying the results on this page with the regular repeat region, or displaying the results with your repeat selection inside of the form, but not both.

I'm glad you got the other page working but when I do the same thing there is no extra modification that is required to make it work properly. So long as I select the correct portion of the form with the elements in them the repeat selection works for the delete every time.

Sign in to reply to this post

simmo515303621

I am not adding an extra repeat region - I am only adding the checkbox to the current region, and wraping the repeat region in a form.

I then add the delete button outside of the repeat region - and then the delete multiple records SB... The results page is the one generated by DA

Sign in to reply to this post

Eric Mittman

The process you have reviewed seems fine but the problem is that you are working within a results page. The results page is designed to list all of the records from your results recordset. This makes use of a repeat region, I think this is the problem you are having on this page.

Instead of using the default DataAssist results page you should recreate the display area of the page. You should remove the repeat region that is there by default and add in your own form in it's place. In the form add in your checkbox and then add the label next to it from the bindings tab for the value you would like to display. Once it is all setup just highlight the label and the checkbox next to it and apply the repeat selection.

Double check it after you add in the repeat selection to ensure that the submit button is outside of the loop. Once the page is setup like this you should be able to add in your Delete Multiple server behavior and have it work without issue.

Sign in to reply to this post

office377308

delete multiple records: never worked.

Whenever I apply the "delete multiple records" from data assist, nothing ever happens. I followed exactly all the descriptions and tried out several variations of this, ie.e Dreamweaver's built-in Repeat Region, then went back using Repeat Region from Data Assist instead. Marked only the line which should repeated. As is described here.
Is there a special form entry necessary?
I have previously used Felixones multiple delete function and it always worked. I deleted it from my extension folder because I thought I might have a more complete solution with WA's Data Assist suite. But it never worked for me.

Sign in to reply to this post

Eric Mittman

In order to use the DataAssist Delete Multiple Records server behavior you will need to make sure that you have the repeat selection properly applied to the form including the form element that has the id, this should be a checkbox.

Once the repeat selection has been applied adding the multiple delete should bring up the multiple delete server behavior interface. In here you just specify the table, the id column, and what element represents that column in your form. It should be a checkbox that has the value bound to the id column from your recordset. I'm including a screen shot of what the interface should look like for the multiple delete. Please post back with some more info about what you are experiencing and the result you are getting after the steps you are trying.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...