close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Special characters in email body not displaying correctly

Thread began 9/27/2019 12:47 pm by Roxana | Last modified 9/28/2019 5:31 pm by Ray Borduin | 53 views | 10 replies |

Roxana

Special characters in email body not displaying correctly

In the confirmation email, instead of displaying "für" it shows "für".

The database connection is set to $connSegufixNew->set_charset('utf8');

I also added <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> to the head section of the email body with no success.

Other than the email body, I don't have any problems with special characters on the site.

Sign in to reply to this post

Ray BorduinWebAssist

The email itself has a charset setting you probably need to set. You can configure that in the email server behavior by clicking on the mail settings icon.

Sign in to reply to this post

Roxana

Hi Ray, I made the change, but it didn't help.

Sign in to reply to this post

Ray BorduinWebAssist

Please attach a copy of the page:
webassist/email/waue_quote_success_germany_1_body.php

Sign in to reply to this post

Roxana

page attached

Sign in to reply to this post

Ray BorduinWebAssist

Is the content coming from the database? What coalition is set in the database for that column? Is it utf-8 as well? If you go to that column in phpMyAdmin does it look right there? It could have been an issue when inserting the value into the database in the first place or a mismatch between the database coalition and the connection charset.

Sign in to reply to this post

Roxana

The database coalition is set to utf8_general_ci.

On the webpage, same content, it displays correctly.

First picture is success page, second picture is from the confirmation email.

Sign in to reply to this post

Ray BorduinWebAssist

Can I get FTP access and a URL with steps to reproduce? I'll have to take a look and debug it. Usually if the Database, Connection, Email, and page all specify a consistent charset, you won't have an issue like this... so I'd need to debug it manually to determine why it isn't working in your case.

Sign in to reply to this post

Roxana

To reproduce go the the provided URL, put a product in the cart, on the checkout page choose "Deutschland" from the drop down menu, and on the confirm page choose "Angebot anfordern".

It needs to be in German, because English has no special characters.

Sign in to reply to this post

Roxana

This post has been deleted.

loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...