close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Admin update page not showing correct data

Thread began 6/13/2018 3:55 pm by tmcbinc99963 | Last modified 6/15/2018 4:59 pm by Ray Borduin | 135 views | 3 replies |

tmcbinc99963

Admin update page not showing correct data

I'm adding an 'Industry' checkbox list and a 'Testimonial Company' text field to an existing admin Update page. Can't seem to get the correct data to show up on the Update page after clicking the pencil icon.

In the Industry checkbox, only the fourth record shows as checked, even when there are multiple records and the fourth one has been deleted. Not sure why it would only show one, or the fourth rather than the first. I've looked in three places for the solution: Update Multiple Records SB, Managed Relational Tables SB and checkbox value attributes. In the Update Multiple Records wizard, I've tried binding to either the form, session or recordset with no change. It seems like a 'value' attribute issue, as it looks like there's some old validation text in there, but don't know how to strip it out, then locate the correct value. Tried looking at the MRT, but not sure how to troubleshoot it.

In the Testimonial Company text field, I can get it to show the correct ID by using a session variable from the Insert page, or the actual company name (first record only) by using the recordset. But can't get it to show the company name from the correct record. The Update Record binding is set using the form's text field name attribute.

DW page attached.

Sign in to reply to this post

Ray BorduinWebAssist

I think I have it working properly for you. Please test and see. You had a few columns and values that appear to have been set wrong that I was able to update in the manage relational table server behavior.

Sign in to reply to this post

tmcbinc99963

There are several issues with multiple admin pages:

Detail page
Lubes show same lube multiple times
Industry Type shows all industries in table, though only a few are checked
Neither TDS nor SDS file names show up

Search results
Shows multiple listings of the same product
Clicking the Update button on the search page returns the following error: "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'LIMIT 10, 10' at line 6." (there's no URL parameter). There's no error when accessing the Update page by entering the URL manually.

Update page
Industry Type shows only one industry; not the correct one
Testimonial company only shows first record; not the correct one
On update, it deletes records out of multiple tables and shows 'this record has been deleted' on redirect page. When I search for the product again, it shows 'no records found'.

Attached all admin pages.

Sign in to reply to this post

Ray BorduinWebAssist

We will need to do a premier support ticket to go through this together.

In order to be truly proficient in creating web sites you need to master quite a few concepts that work together:
1) HTML
2) Javascript
3) CSS
4) Database Design
5) SQL
6) PHP

Depending on where you are least proficient, there are many books you can read about any of these topics. Using our tools puts these 6 concepts together, but an understanding of the underlying technologies is always helpful particularly when debugging when things go wrong. I'll attempt to answer your questions here, but really a 1 hour training to go over these would probably be necessary to fix them efficiently.

If you want help through the forums I'd suggest:
1) Post only one issue at a time and not three
2) Include a URL and steps to reproduce the problem so I can view it on the web directly
3) Provide FTP access if I don't already have it so I can look at your files
4) Verify that the data in the database is correct and describe how it works since I won't likely have access to your phpMyAdmin

Detail page
I'm not entirely confident that the issue is only in the php code and not a data integrity issue. I'd first confirm that the database has the correct records to begin with.

If the database is correct, then it is probably a matter of writing the correct SQL statement. Most likely adding a GROUP BY clause, but I'd need to talk it through with you to see what you are trying to achieve and how the database is structured.

Search results
The multiple repeat issue is a matter of adding a GROUP BY in your recordset sql statement probably. The error on the update is a missing url parameter most likely.

Update page
The missing record after update is probably because you aren't inserting the correct record in a joined table and your recordset uses an INNER JOIN. If the associated record in a related table is missing then the result won't be found.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...