close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Creating Data Assist from pages <New From Blank>

Thread began 3/03/2018 12:35 pm by vanroojdotcom | Last modified 3/09/2018 12:53 pm by Ray Borduin | 204 views | 10 replies |

vanroojdotcom

Creating Data Assist from pages <New From Blank>

After purchasing Data Bridge I have tested a few wizards in preparation for an actual website I need to build. I created an Application Type = "Product Administration" and clicked on the [x] Create database table for me.

This way I would be sure it works without making changes - the default baseline practice.


I am now moving into the make my own changes stage and have encountered a few problems:

1) Using the Application method, when I try to delete a column in Manage Pages - Dreamweaver Crashes. OK so I have to create the initial pages using all columns and perhaps simply delete the relevant input text box after. A work-around.

2) When I create the pages using <New From Blank> option, the update page (on the website) does not update it simply hangs for a bit, I can search, see the results, insert new and view the details page, but cannot update an existing record. Am I missing some manual step that I must do before uploading files? I click on the recordset but get a 406 error code? Is this a known issue?

This has me a bit worried because I need to add a new database next of my own creation - Make and Model of Car. Without update option this is not going to work.

3) When I create Application type for the product catalogue - on manage pages, I only have the option of Image Source, Image Alt Text, Title, Description, Price. But I need more Bindings for my products. I can't add anymore Bindings (or columns like you can in the Administration Section / New From Blank).


So I'm a bit stuck

Admin Application - can't remove columns
Catalogue - can't add columns
Blank - can't get the update page to work


Trying to change Recordset results in ERROR 406



Any Ideas?
Many thanks
Christopher

Sign in to reply to this post

Ray BorduinWebAssist

1) I wasn't able to reproduce that error, but I am using the beta version. Would you mind installing it and seeing if this is still a problem?
2) Update should work. If you could give me FTP access and a url to reproduce the problem I could take a look and let you know what needs to be adjusted.
3) You can change the page layout type to "Standard" and it will allow you to add more columns.

The 406 error I haven't seen. I think it is because of mod_security that is installed on your server preventing database information from being shared with Dreamweaver. If I could get FTP access and your website url I would be able to try to reproduce the issue and see if there is something I can do to get it fixed.

Sign in to reply to this post

vanroojdotcom

Hi Ray

Thanks for getting back to me! I've installed the new Data Bridge and it won't create the pages for the <New From Blank> option. I keep getting two errors and then it just stops running. (See screenshots).


I can't see the "Standard" option for the Results Page, only 'Public' and 'Administration' (See screenshot)

Deleting a column in the new version still crashes when removing unwanted columns from the Products table.



Hopefully this will help in resolving the issue


Many thanks





EDIT:

Ray. It's took me a while but I've decided to create a <New from Blank> for the same database table I've created for different page combinations. It's only got two fields 'ID' and 'Make' - I've added it to the homepage above so you can click on each link and see how by adding INSERT and UPDATE pages, the work flow breaks.

http://websitevisual.co.uk

Sign in to reply to this post

vanroojdotcom

Hi there Ray.

Just an update on the HTTP Error Code 406 Not Acceptable issue


This is the response from the hosting company

From what i am seeing it may be caused when the server cannot respond with the accept-header specified in the request. If it is unacceptable on the server that is not something that can be changed on a shared platform. If you wanted to change that setting you would likely have to have a VPS or dedi account so you can manage your resources more specifically

In other words these Recordsets don't work! So I'm stuck what to do.

Do you think the MysQLi generated recordset will work?


You said you may have an idea what is causing the issue?


Any help would be appreciated.



EDIT TO MY MESSAGE:

Ray, I really appreciate all the help your giving. Just hang fire on this for a few days. I'm going to install PHP / Apache / Sequel Pro on my Mac and spend a day running it from this to give the code a test run! I'll let you get back to your daily work-load and contact you with proper questions when I've got everything sorted in my head.

Sign in to reply to this post

Ray BorduinWebAssist

It appears there is a security setting on your server preventing Dreamweaver from posting a SELECT statement. I can reproduce the problem whenever I post to your site with a SQL SELECT statement in the post contents. Unfortunately this is done by a native DW module that I can't easily bypass.

I'm looking into options now, but I won't likely be able to find a simple solution for you.

The update page in your sample only has one problem... for some reason the connection file on the update page is too low on the page. You can manually move the connection require_once statement from lower on the page to the top and then that page will work.

In the all example a lot of code that should be on the results page was added to the update page instead. These issues may be a byproduct of the 406 error. If you run the wizard again with all of the pages do you get the same result? Are there any errors while the wizard is processing?

New from blank probably won't work because it is trying to get the column list, which fails with the 406 error and then you get the other errors when no columns are found.

Sign in to reply to this post

Ray BorduinWebAssist

I was able to make an update to the Beta version that should get around the problem and allow you to connect to databases through dreamweaver even with the Apache security mod that prevents posting SQL statements. Please try installing it and let me know if you still have problems.

Sign in to reply to this post

vanroojdotcom

Ray

Thanks for your help. I'll delete Dreamweaver / previous Data Assist and reinstall everything and start from new. BTW, this new Data Assist will it work with PHP 7?

Sign in to reply to this post

Ray BorduinWebAssist

Yes, the beta version has been updated to work with PHP7

Sign in to reply to this post

vanroojdotcom

Hi Ray

I've deleted Dreamweaver / re-installed and installed the latest data-assist extension. But the problem has not been resolved, previously when I created a new recordset, I was able to select a database and click TEST and actually see the result of any query. It was only when the recordset was generated that the 406 error code popped up (when selecting the triangle to see the bindings).

Now when I click TEST (in the recordset panel) I get the error "HTTP Error code 500 Internal Server Error". But in the WA Database panel it shows the database and tables so it seems to be seeing the database.

However the pages generated using the Data Assist Pages wizard are working (up to a point), I can select a table and it show the fields, so it is connecting to the database.

EDIT - JUST TO LET YOU KNOW THE ACTUAL PROCESS, WHICH MAY HELP YOU NARROW IT DOWN:

I created a recordset - fine and when it connects I can see all the tables in the database, and the relevant fields. At this point, if I click TEST I get the HTTP Error code 500 Internal Server Error. However, if I ignore the error and just clock OK it will create the recordset. If I click on the expand triangle, it opens up and you can see the Bindings. (It was at this point in the previous version - trying to expand the Recordset that I got the "HTTP Error Code 406 Not Acceptable" error) so that issue has been solved.

So to all intents and purposes (if I hadn't clicked test) everything would look fine. I can drag a binding into the index file - it creates the 'echo' element. Upload the file and you can see the FIRST RECORD of the table.

However, if you try to use Repeat Table or Repeat Region - you still only get the first record showing. It was at this stage that I went back clicked test and got the error. So it maybe that the Repeat element not working is related to the HTTP Error code 500 Internal Server Error.



• Last Version: You could click test and see the result in the window - but you could not see the bindings
• This version: You get an error clicking test - but you can see the bindings (although I can't create a Repeat of more than one result)




Hope this helps you.

Sign in to reply to this post

Ray BorduinWebAssist

I've updated the extension to fix the TEST button. If you reinstall it should work now.

If you are using "Repeat Selection" instead of "Repeat Region" then it won't update the number of rows in the recordset. I'm not sure if that is what you are doing. If you attach the page I could take a look.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...