close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Cannot create connections (or anything) on CC2017

Thread began 9/05/2017 10:18 am by Orian | Last modified 9/08/2017 6:23 pm by Ray Borduin | 337 views | 14 replies |

Orian

Cannot create connections (or anything) on CC2017

OK... CS6 was a total bust. So, I tried to install on my CC machine.

After "jiggling the handle" for a while and, downloading the DMX extension manager, I finally got the "Databases" panel to show up. But, I can't do anything with it. The "+" is greyed out. And, I DO have a php file open. I also have a site defined for the file even though the panel is complaining about the whole "to use dynamic data...." schpeel.

I used theWebAssist menu up in the menubar and all I can do is attempt to make a database connection there. just like in CS6, it simply says "Unidentified Error has occurred"...

I had such high hopes for this plugin. but, now, all I can say is "What the heck do I have to do here?"

I created a manual MySQLi connection to my database (remote). And, my settings DO work. At least there are no exceptions thrown from connection script.

how do I get around this "Unidentified Error"? and get back to work?

The system is Mac OS 10.12.6

Sign in to reply to this post

Ray BorduinWebAssist

I see you posted this same issue in another thread. I'd stick with CS6 for now since the CC versions have bigger issues and the error you were getting in CS6 I'm sure you would get in the CC version since it is an issue with your testing server settings. If you send me your testing server settings I may be able to spot what you have wrong.

Just make sure you have a testing server defined for your site and that you can copy and paste the value you have entered for the Website URL into a browser and see the site you are working on in your testing server.

Sign in to reply to this post

Ray BorduinWebAssist

If you still need help I can do a screen sharing session in order to look into it with you. Just post a US phone number or Skype contact information and I can set up a call.

Sign in to reply to this post

Orian

Thank you. I will make sure to get all of the essentials set up before it comes to that. I am using one of my personal domains as a testing site. Same server. just a different domain. I will be in touch when I get that and the new mysql users added to the database.

Sign in to reply to this post

Orian

Ok. I have done about all I can. It is installed. And, I got it to successfully create a connection... But, now it won't recognize it unless I recreate it...

Sign in to reply to this post

Ray BorduinWebAssist

That sounds like the CC2017 issue that we have the large warning about on top of all of our pages.

1) Data Bindings don't work from inside commands using the lightning bolt icon
2) Connections don't display in the Database window once created, although you can still use them to create recordsets and in database manipulation

Sign in to reply to this post

Orian

I see.
I didn't see the warning until after purchase. I thought I was safe, since I am using Mac - although it doesn't really matter at this point.
But, since I just renewed my CC last month, I had no choice in versions to download. Is there a timeline for updates to fix this? workarounds? ways to "jiggle the handle"?

UPDATE! I just located instructions on the Adobe website to revert to previous versions. It has been there the whole time. I will be doing this and, reverting to DW2016 when I get home from work this evening.

Sign in to reply to this post

Ray BorduinWebAssist

Yes, any CC subscriber has access to previous versions from the creative cloud manager.

Sign in to reply to this post

Orian

Sir; with all due respect, I am BEYOND frustrated with this extension. I have been fighting it for three days now and, things are only getting worse.

I have, indeed downgraded my CC to DW2015, losing much of what I renewed with Das Adobefuhren to get. The extension does not work on 2017. That's fine. I got that.
But, it IS supposed to work on 2015... and it is not.

I need to get to work - either learning more about MySQLi or PDO. Certainly NOT futzing around with an extension that needs to be coddled in order to do anything.

After another two hours of begging this thing to work, I finally got the WebAssist menu at the top menu. The interface is extremely buggy and after entering all the fields, and testing the connection... It (crashed?/disappeared) and I had to start all over again. The second time was no better and, I had to walk away before things started getting broken.

I exited... restarted... rebooted... and finally the WebAssist menu graced me with its presence again, and allowed me to create a connection.
Then the Data Modeling screen appeared... With NO idea what to do there, I searched the site... found an outdated/unhelpful tutorial from before the integration of several extensions into one.
I could not find anything such as an "idiots step by step getting started"... cause that what I thought... "I must be an idiot".
At any rate, I just clicked OK on the data modeling screen and tried to move on.

I recreated my index.php before all of this. So, I opened it... And, the DATABASE panel was nowhere to be found... nowhere!
I could not figure out how to open the darned thing... more futzing around, and it finally appeared in the middle of the workspace. So, I drug it over to rest beside the "Behaviors" panel...

Time to create a recordset...FINALLY!
Alas, the SAME problem from CC2017 happened again... The "+" for the server behaviors is GREYED OUT! And, another hour of futzing around has not made it to light up...

Sign in to reply to this post

Orian

i have tried removing and reinstalling this thing several times, I even removed and reinstalled DW again... Went so far as to update java (I forget the rationale for that)

And, now that I tried to delete the extension forever. It causes this every time I restart DW... Can I just have a refund please? It obviously doesn't work on CC

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...