close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Empty Delimiter Error

Thread began 10/29/2012 5:38 pm by blackweldermhe400113 | Last modified 10/31/2012 12:50 pm by Jason Byrnes | 880 views | 7 replies |

blackweldermhe400113

Empty Delimiter Error

Hey guys,

Was wondering if you could help? I was looking through the previous threads and found two related posts, but nothing that worked for me. My nav isn't linking properly when using relative nav links within the CSS Menu Writer because the plugin is placing a forward slash in front of my link (ex. /news.php). I'm running localhost off my machine using xampp and php. One of the posts mentioned leaving the variable value for the localRoot and remoteRoot references in the menu.php file empty, but when I do so it gives me an empty delimiter error on line 6 of the menu.php file. Is there a fix for this?

Thanks
Chris

Attached Files
empty_delimiter_error.txt
Sign in to reply to this post

Jason ByrnesWebAssist

can you send a link to your site where i can see the problem?

The links should be site relative, the forward slash is added at the start of the links to denote the site root.

Sign in to reply to this post

blackweldermhe400113

Question?

The site is actually being hosted locally and I'm using my testing server so there is no live link currently, but is there a way to set the value of both the localRoot and remoteRoot to null or blank? The problem arises when I'm using them as blank because I don't need the "/" set in those values.

Thanks
Chris

Sign in to reply to this post

Ray BorduinWebAssist

If you upgrade to Design Extender it no longer uses the remote and local root variables at all.

In this version it needs to set the site relative link starting with a slash to work properly, since you may have the same menu on pages in different sub directories, it always uses a site relative link to function properly. Why is it that you don't wan to use the site relative location?

Sign in to reply to this post

blackweldermhe400113

Site Relative Linking

The navigation is only being used on pages that are within the site root, and unless I used it on a page within a sub directory for say maybe a cms or something they'll only need to be relative. Also, it's a pain not to be able to test the navigation locally before posting live. I really wish this plug in didn't behave in this manner. So, what you're saying is the navigation will not work until it's posted live? I wish I had known about this prior to purchasing this plug in with my Super Suite. The plug in barely functions as it should anyway. It took me three attempts to style and define my theme for the nav menu, before giving up and having it render half way complete, because the plug in kept crashing, and even still I had to go and customize the remaining three levels of my nav by hand. I might as well have coded the thing from scratch. Please forgive my frustration, but after having spent what I consider to be a lot of money on your suite of Dreamweaver plug ins I expect them to function better then they do, and don't think spending another $400 on Design Extender is an option for me.

Sign in to reply to this post

Ray BorduinWebAssist

It is designed to work with both a local testing and live server. It allows you to set both a local and remote root so they can be different.

If you have time I'd love to set up a screen sharing session so you can show me what you were trying to do and where it was failing for you so that we can try to correct those issues and get it working properly in the future.

Sign in to reply to this post

blackweldermhe400113

I would love that but...

Yeah I had seen that there was a local and remote value to be set, so I figured it could be tested locally, but then was also seeing people with the same issue complaining that local testing wasn't possible. I would love to sit down and try and resolve this with you through a screen sharing session, but my schedule wont permit me to till maybe Friday. Until then maybe I can take some screen shots of the error message I'm seeing and possibly my site definition and root structure. I should have them posted this evening, and then we can set a meet time for the remote assistance.

Thanks for the help.

Sign in to reply to this post

Jason ByrnesWebAssist

Ok, we can take a look at this with you on Friday.

I will start a support incident so that we can share contact information and arrange for a time.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...