close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Installing wiped out my Power CMS Login Info?

Thread began 3/01/2012 2:41 am by cldsk | Last modified 3/28/2012 2:23 pm by Jason Byrnes | 1811 views | 17 replies |

cldsk

Installing wiped out my Power CMS Login Info?

This is my first time using security assist and I installed it on the site after I set up PowerCMS through DesignExtender (added content and created a user).

Once I uploaded the pages, the page that I protected did bring up the login page, and I tried creating a user (same email as one of my PowerCMS users) but it gave me an invalid email addy as it was already in the table.

When I tried to login to the cms (admin_cms) link, now I get this error:

Fatal error: Cannot redeclare wa_authenticateuser() (previously declared in /homepages/30/d404790350/htdocs/argoaquaticsclub/webassist/security_assist/helper_php.php:28) in /homepages/30/d404790350/htdocs/argoaquaticsclub/WA_SecurityAssist/Helper_PHP.php on line 46


It appears I am now stuck...did I do something wrong? Can I not use these two products together? Thanks so much for your help!
~Chris

The site that I am suing it on is: index2.php (temp link)
The protected page is director.php
Admin is: admin_cms

Many thanks!

Sign in to reply to this post

Jason ByrnesWebAssist

this is an issue using PowerCMS on security assist pages, see this post for details on fixing the problem:
showthread.php?t=15730

Sign in to reply to this post

cldsk

Thanks, worked sort of

Thanks for the tip. I did comment out that section, which did allow me to bring up the CMS login, but when I try to login I now get this error:


Fatal error: Cannot redeclare wa_authenticateuser() (previously declared in /homepages/30/d404790350/htdocs/argoaquaticsclub/webassist/security_assist/helper_php.php:28) in /homepages/30/d404790350/htdocs/argoaquaticsclub/WA_SecurityAssist/Helper_PHP.php on line 46


Any ideas on this one?
Thanks so much!

Sign in to reply to this post

cldsk

This might help?

Not sure if this is part of the issue or not, but I did select in the Security Assist to use the PowerCMS Users and the two users that I do have don't meet the user name/password requirements of Security Assist (they do/did work fine for the PowerCMS). So when I try to login to the Protected page using my users created or PowerCMS, they don't meet the required length/etc.

This might be a further issue or shed light onto the current issue...not sure. Your help is greatly appreciated!
~Chris

(PS: for this purpose I am not too worried about not having the Live Edit for the Protected Page, the other pages it would be great to have it, but not super worried about it, if that helps!).

Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into this issue further.

To view and edit your support ticket, please log into your support history:
supporthistory.php

If anyone else is experiencing this same issue, please append to this thread.

Sign in to reply to this post

cldsk

Thought was fixed...I was wrong

Hello, I thought this problem was fixed through the ticket as I could log into my CMS (so I didn't bother to check trying to edit anything)...I am just about to head to an appointment with client and tried to fix some content through the CMS, but now I get this error when I hit the edit button in the CMS:

Fatal error: Cannot redeclare wa_authenticateuser() (previously declared in /homepages/30/d404790350/htdocs/argoaquaticsclub/WA_SecurityAssist/Helper_PHP.php:8) in /homepages/30/d404790350/htdocs/argoaquaticsclub/webassist/security_assist/helper_php.php on line 58


I am also having a problem on my secure page...when I try to log in (director.php)
I was getting the log in screen again with the message "You have successfully logged in" but it wasn't redirecting to the original page. When I changed the redirect in the two "SecurityAssist Authenticate User" pages to director.php on successful login, now the login page just shows without a message...I am not sure why it seems so hard to incorporate Security Assist with PowerCMS...please help. thanks so much!

Sign in to reply to this post

cldsk

So fortunately I was able to get the Power CMS fully working again just in time for my meeting (thankfully)

this fix posted in earlier forum worked:
change:
PHP Code:
require_once( "../WA_SecurityAssist/Helper_PHP.php" );
to:
PHP Code:
//require_once( "../WA_SecurityAssist/Helper_PHP.php" );

however, I am still having trouble on the login page getting it to redirect.

I am unsure how the WA_CMS page was changed, I think Ray posted a new one for me...would this have been changed in the posting of the SecurityAssist Authenticate Users behavior? If so, I am unsure how I am suppose to do any updates with the Security Assist without screwing up the PowerCMS...I appreciate your help in trying to figure this issue out and working out the login page problem.

Sign in to reply to this post

Jason ByrnesWebAssist

send a copy of the login page, so i can take a look at the code.

Sign in to reply to this post

cldsk

Attached

Attached is the login page and the director page. I also have to create a new password protected page "other.php" I fear that this will have the same problems...how can I get around from having these issues when i secure a page with SA and PowerCMS?

Many thanks!

Attached Files
login.zip
Sign in to reply to this post

Jason ByrnesWebAssist

on the director page, you are using the "Log in success" access rule, you should be using the "Logged Into <Your User table>" (where <Your User table> is the name of your user table) access rule instead.

this problem will happen in any page that you have both CMS content and security assist.

to correct the error, you will need to manually comment the ../WA_SecurityAssist/Helper_PHP.php require once line:

//require_once( "../WA_SecurityAssist/Helper_PHP.php" );

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...