close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Has anyone SUCCESSFULLY gotten this fixed (Unable to edit your database with the...)

Thread began 11/10/2011 12:07 pm by sales189614 | Last modified 11/11/2011 2:04 pm by sales189614 | 932 views | 6 replies |

sales189614

Has anyone SUCCESSFULLY gotten this fixed (Unable to edit your database with the...)

I am seeing a lot of threads with this issue, and as stated by many others they all end with a support ticket being opened, but they opened a ticket for me also three days ago, but I haven't actually been called, despite asking multiple times in the ticket and here in the forum to actually get the phone call, so I wanted to turn to others and see if anyone has actually been called and had this issue successfully resolved???

I have seen a couple solutions, but I have tried those and none of them have worked (reinstalling the extension and making sure the database user password is correct, even resetting it, as well as making sure my site definition is correct, but with no luck)

Just like eric431966, I can connect to the server in Dreamweaver and it connects to the server just fine, the testing and remote server are correct, but when clicking, "Add Content to Power CMS" I get the error, "Unable to edit your database with the provided user credentials. Please make sure the connection user has write access to this database. (You may need to upload the connection to the server if you have made changes recently)"

I have verified the connection details in the connection file are correct, and uploaded it again, of course with no luck.

So if anyone here has actually been contacted, it would be great if you could post and say what solved the same problem for you, and see if that could help the rest of us who haven't been contacted and are still frustrated. And if a support rep reads this, please look at ticket #135314 and call me. I really need to get this resolved. Seems like I very rarely am able to just use a product I buy from WebAssist, I usually have a problem and sometimes I can get it resolved, and other times I can't and have to get a refund.

So if anyone has successfully resolved this, please, please, please post what fixed it for you. "If" I am contacted by WebAssist and resolve the issue, I will definitely post and let everyone know what resolved it for me.

Thanks guys.

Sign in to reply to this post

CraigRBeta Tester

yes

showthread.php?t=23016

Sign in to reply to this post

sales189614

Thanks Craig. Unfortunately I have tried that, but it did not fix the issue for me. Thanks so much for taking the time to post that, I really appreciate it. I am livid right now that they have not contacted me yet.

Sign in to reply to this post

brandoli400690

Database errors

I experienced the same thing yesterday using it for the first time and it seems to be fixed.
I followed the various instructions on the forums - - checked permissions, deleted the non-working install, and re-installed.
I wish I could say definitively what solved it but I think it had something to do with physically uploading the first CMS page to the site, and accessing it from the admin page.

Sign in to reply to this post

Jason ByrnesWebAssist

sales189614: I have let our engineering team know that you are awaiting a response for this issue, they should be contacting you soon.

Sign in to reply to this post

sales189614

Jason- someone just barely contacted me. I'm hoping they can resolve this, but it sounds like I am going to have to manually create the database tables, which if that turns out to be the case is ridiculous, I mean why would I purchase this if I just have to end up creating the database tables manually? I'm not happy at all with this, and am seriously going to have to rethink future purchases with WebAssist because of all of the problems in the past and currently with WebAssist's products, which is sad because when they do work they're wonderful. But I am honestly at the point where I think that I would probably be better off in the long run to just have my own programmer (or even possibly an outsourced programmer on the cheap) write me something that I can also just use over and over again for my clients.

And the reason I am leaning towards that instead of purchasing any WebAssist products in the future is MOSTLY because of my experience with WebAssist's customer service. It's about an 80% chance I will end up losing this client because of this issue, and all because I have been unable to get this done for him in the time that I quoted him, so this has made me look completely incompetent. But here's the thing, I made my first purchase with WebAssist in March of 2005 and in that time have spent a total of $1,961.83. There have been VERY FEW times when I have not had to request support for whatever it was I had just purchased, sometime's having to get a refund, and in all of that time, and this is the part that is making me SERIOUSLY reconsider purchasing from you in the future, WebAssist has NEVER offered me ANY KIND of "we're sorry" WHATSOEVER, either in words or in discounts to try to even act like they cared about me at all. So not only am I upset that I had to wait three days to get someone to call me to help with this issue, but I am more upset that I feel like WebAssist could care less about me individually, or about any of it's customers as a whole. So I am pretty sure that this will be the last purchase I ever make with WebAssist. I think it would be much better for my clients if I just have my programmer develop solutions for me as needed. Like I said already, that is so sad because the things you guys make that do work, are wonderful, but your customer service as a company (as a company, not you individually) is SERIOUSLY LACKING. I would think that in today's economy companies such as yours would be doing everything in their power to make sure their customers are happy customers, I know that I certainly treat my clients in such a way that will make them want to keep doing business with me for many years to come. That's something you guys might want to seriously consider. I may only be one customer, but I would imagine that if something doesn't change, I won't be the last.

If anyone agrees with me, please reply and let them know. If they realize it, maybe they'll start doing something to change it.

brandoli400690- thank you so much for taking the time to post, I appreciate it very much. I have recreated the database as well as the database user etc, with no luck. They are trying to help me now. I will certainly be sure to post my individual solution for others.

Sign in to reply to this post

sales189614

Possible Fix

Ok so I wanted to post the solution because I know from experience that it is VERY FRUSTRATING to see so many posts with the same problem you have that all just say a support ticket was created, and then no one says what the fix was. So although the solution solved it, but then created a whole separate issue in my case, I wanted to at least post this for others.

So this worked to get me past the error I was getting, BUT after uploading the files to the server and then running the install, now anytime I go to the admin, or any page that has to do with the cms, I get a completely blank page. I have even tried running the install again, but it's all blank too. So I am once again waiting to get an answer to fix that in my ticket, but I figured if someone wanted to try this solution to see if it works for you, then at least you'd have a little hope.

Now, I am not 100% certain that the file they provided me to replace the old one is not specifically for me, but I have looked through it and don't see anything that would leave me to believe it wouldn't work for everyone.

I'm a little confused as to why they don't offer this file for everyone as a sticky thread or something so that everyone can download it and not have to wait for a week to get this working. This is obviously a glitch in the program, not caused by something any of us have done wrong, so this is definitely the straw that broke the proverbial camels back for me, I won't be purchasing any additional WebAssist products in the future.

Anyways, these are the instructions that I followed for the fix:

Please download the attached WAPCMS_CreateContent.js file and replace it with your local file in the following location:

C:\Users\<Your UserName>\AppData\Roaming\Adobe\Dreamweaver CS5\en_US\Configuration\Commands

Make sure to have Dreamweaver closed and delete the WinFileCache before restarting.

Of course he didn't specify what WinFileCache was or where it was located, so I had to research that to know what to do with that part and it is:

First, to show hidden files:
Control Panel
Folder Options
View Tab
Hidden files and folders
Select show hidden files and folders

After that is done, then navigate to C:\Users\<Your UserName>\AppData\Roaming\Adobe\Dreamweaver CS5\en_US\Configuration and delete the WinFileCache file, which starts with WinFileCache and then some numbers, then .dat.

Now like I said, after applying this solution, I was able to get past the error that everyone is getting, but now all of the pages I try to access for the cms on the site are blank. I was able to run the install, then after the install completion, all pages are blank. I wanted to let everyone know that, so in case you run into the same issue, then you will not think it is just you.

So we'll see if they help me with that.

Attached Files
cms-fix.zip
Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...