close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Mail.php Missing (UE 4.0.1)

Thread began 6/30/2010 9:36 pm by kevin347925 | Last modified 7/02/2010 6:06 pm by Eric Mittman | 2173 views | 4 replies |

kevin347925

Mail.php Missing (UE 4.0.1)

When trying to send an email from my webpage, I get the following error.

Warning: require_once(Mail.php) [function.require-once]: failed to open stream: No such file or directory in ...webassist/email/PEAR_Mail_using_SMTP_php.php on line 115

Fatal error: require_once() [function.require]: Failed opening required 'Mail.php' (include_path='...') in .../webassist/email/PEAR_Mail_using_SMTP_php.php on line 115

I'm sure that this is probably a quick fix, but I'm not sure where to go from here.

I am using UE 4.0.1

Thanks so much.

Sign in to reply to this post

Eric Mittman

This file should be created by the Universal Email server behavior and be present in your local site. Was this file skipped on upload? Check the local site to see if it is in the location specified and if it is not you should create a new page and try applying Universal Email to this new page. Applying the server behavior should create the file for you that you can then upload to your server. Please give this a try and let us know if there are any further problems.

Sign in to reply to this post

kevin347925

I uploaded the entire webassist folder, and the Mail.php file is not located in the local site folder.

I ran the UE behavior multiple times with no luck.

Sign in to reply to this post

kevin347925

FYI, in running tests on completely new pages, I found that the assigned redirect was not working. Instead of going to the redirect page, the page remains blank--no error messages.

Finally, when I test UE on a completely new page, Mail.php does not populate.

Sign in to reply to this post

Eric Mittman

You should try renaming the configuration folder to undo any corruption that might be present in your current install. Here is a link to the instructions for this:

showpost.php?p=12293&postcount=2

Once you go through the steps and remove the currently installed extensions then re-install Universal Email please test it out and let us know if the issue persists.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...