close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Can't 'Browse Server' on Image Properties

Thread began 6/04/2010 1:16 am by bill.dawes319233 | Last modified 6/07/2010 7:29 pm by Eric Mittman | 1052 views | 4 replies |

bill.dawes319233

Can't 'Browse Server' on Image Properties

On the admin CMS edit facility, I have a wee glitch on the Image Properties box. I can upload files no problem. But when I click the Browse Server button on the Image Info tab, it opens a dialogue box (entitled)

index.php?lang=default&kfm_caller_type=fck&type=Image

but doesn't display anything.

I've had a look at the code of the page but it's a bit beyond me to debug. Any ideas?

Many thanks

Bill

Sign in to reply to this post

bill.dawes319233

the plot thickens

OK, so I turned up the error reporting on that page, and discover that:

Fatal error: Call to undefined method MDB2_Error::fetchAll() in /home/mysite.com/www/sitesculptor/HTMLEditor/editor/plugins/kfm/includes/db.php on line 43

so I had a look at the code on that page, and the offending section appears to be

function fetchAll($query){
return $this->db->fetchAll($query);
}

but now I really am a long way out of my depth. Any wa_iRite experts out there who can help point me in the right direction here? Is anyone else having a similar problem?

Sign in to reply to this post

Eric Mittman

I have seen an issue that is similar to this one. I'm not sure whey the error is occurring for you in the current setup unless there are some problems with some pages in the CMS files. To determine if this is the problem try updating the entire HTMLEditor folder from your site with a newly downloaded one and test it to see if experience the same issue. Please post back and let us know what the result is after trying this.

Sign in to reply to this post

bill.dawes319233

no joy yet

I have downloaded the entire site and put it on a local testing server on my computer, and it all works absolutely fine - the Browse Server button does exactly what it is supposed to do.

So there clearly isn't anything wrong with the pages themselves. Everything does seem to work. But just not on my server...

So is it maybe a permissions thing, or a compatability thing?

My server is linux, running php 5.2.1 - permissions are set to 777 on the files and cms_files

The only thing I can think of is that at the moment the sitesculptor site is not at root level for the domain, it's sitting as a subdirectory of a website. Is there something in the site somewhere that defines the path to root, that is needed for this to work? I had a look but couldn't find it. (Everything else is working fine though).

Sign in to reply to this post

Eric Mittman

I have talked with some colleagues about this issue and for one user that was experiencing the issue the problem seemed to be related to the version of PHP that was installed on the server. When the version of php was updated the problem no longer occurred. I'm not sure if this is an option for you but you should check as it might resolve the problem. I'm currently unaware of any other server configurations that would cause this error to occur. Please check on this and get back to us with what you discover.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...