close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Browsing Server in HTML Editor

Thread began 5/21/2010 10:49 am by todd368532 | Last modified 5/26/2010 6:01 pm by Eric Mittman | 943 views | 4 replies |

todd368532

Browsing Server in HTML Editor

OK, I need help with this. I have search the forums here pretty thoroughly but didn't see anything addressing this specifically, so I apologize if this is a repeat of already answered issues.

File Manager Issues: In HTML editor, when I want to upload a file to server, it works fine and I can link to a document, image, place an image in the editor, etc. That all works fine.

However, if I browse server for resources I have uploaded before, the left side of the File Manager seems inactive. Like there's nothing for me to do. All I get is the icons for trash and a clipboard. No expand or collapse functionality, no directories being listed, nothing. Just emptiness.

I need a client to be able to browse server for items already uploaded. HELP!?

Screen Grab:

Sign in to reply to this post

Larry

I am now having the same problem since upgrading to Power CMS 2, I can only browse to the image folder, If I want to link to another page in the site, there is no way to browse to those pages or file.

Any and all help would be appreciated.

Larry


Originally Said By: todd368532
  OK, I need help with this. I have search the forums here pretty thoroughly but didn't see anything addressing this specifically, so I apologize if this is a repeat of already answered issues.

File Manager Issues: In HTML editor, when I want to upload a file to server, it works fine and I can link to a document, image, place an image in the editor, etc. That all works fine.

However, if I browse server for resources I have uploaded before, the left side of the File Manager seems inactive. Like there's nothing for me to do. All I get is the icons for trash and a clipboard. No expand or collapse functionality, no directories being listed, nothing. Just emptiness.

I need a client to be able to browse server for items already uploaded. HELP!?

Screen Grab:  
Sign in to reply to this post

Eric Mittman

There may be an issue with the current files that are loaded for the editor. You should try replacing them with the downloaded versions to see if it clears up the issue for you. Before you use the downloaded files make sure to backup your existing site and replace all of the files and folders except for the following:

admin
Connections
files

You should leave these alone and replace all of the other files and folders. After you have copied over the new files you can check to ensure that they are not read only. If you still experience this problem after trying this please post back and let us know.

Sign in to reply to this post

Larry

Browsing Server in HTML Editor

I remember I had this issue with Power CMS 1 also.What we did to correct the problem was to edit the /CMS2/HTMLEditor/editor/plugins/kfm/configuration.php file.

On line 52 I made the change to this,

$kfm_userfiles_address = '../../../../../../public_html';



And then on line 128 I had to remove php from the ban dangerous files from being uploaded.

After that I can browse all of my files and folders when inserting links or other files.

There does seem to be one more issue though, when the link is inserted, it always inserts the path from the CMS folder as in

/CMS2/files/ContactForm/contactus.php

now the /CMS2/files should not be there.

So, is there any fix or any way to fix this issue?

Thank you

Larry


Originally Said By: Eric Mittman
  There may be an issue with the current files that are loaded for the editor. You should try replacing them with the downloaded versions to see if it clears up the issue for you. Before you use the downloaded files make sure to backup your existing site and replace all of the files and folders except for the following:

admin
Connections
files

You should leave these alone and replace all of the other files and folders. After you have copied over the new files you can check to ensure that they are not read only. If you still experience this problem after trying this please post back and let us know.  
Sign in to reply to this post

Eric Mittman

This seems to be the same issue that was described in this thread in post #7.

showthread.php?t=11648

There has been no update the this functionality, the link to the file will use a site relative link rather than a document relative link. Did you ever pursue this in the support ticket? I did not see any resolution.

Sign in to reply to this post

amandacomer368110

Path issue PowerCMS

This post has been deleted.

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...