close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Form with Ecart Add button

Thread began 3/23/2010 4:06 am by deno1965 | Last modified 3/26/2010 4:20 pm by deno1965 | 910 views | 7 replies |

deno1965

Form with Ecart Add button

O.k. here goes. I had this problem before and knew the steps to take, but now can't get it to work. I have a form that is multi-part. It's a logo design form that people input their info for a logo design and can upload images for the design, then a email is to be sent to me with the form images and info, the person who filled out the form is then redirected to their cart for payment. I cannot get the add to cart button to redirect to cart. I know the button generates its own form code, but last time for it to be multi functional (send the email as well as redirect to cart) it had to be within the existing form. Most of my forms are like this and they are not working, need help bad. Thanks.

P.S. I made field and graphics changes to my forms, then they stopped working. But no code was changed. I just need to figure out how to get it to send the email as well as go to cart with 1 click, basically.

Sign in to reply to this post

Eric Mittman

It is fine to use your own form but you still need the add to cart server behavior code on the page. You can modify it to work with your own form though. If you want to have Universal Email on the page and an add to cart you should have the Universal Email occur first, then the add to cart afterwards.

The add to cart server behavior will take you to the cart page if you specify this when applying it to the page. This should be where you start, you can then update the add to cart server behavior to work with your own form.

Are you able to get the item adding to the cart and the email sent? If so you should be ok to just add in a redirect to your cart page. Please post back with these details and include a copy of the page in question so we can see what is going on with it.

Sign in to reply to this post

deno1965

Add to cart button

Its not doing anything now. Not adding to cart or the email. Here's 1 of my forms-
nonflashlogo.php

Sign in to reply to this post

Eric Mittman

Ok, you should be able to have the add to cart on this page and the Universal Email server behavior. Post back if you have any problems with this or if you have any other questions.

Sign in to reply to this post

deno1965

Add to cart button

Hi Eric,

Eric, not to sound harse, but that was the point of the original post. There is a add to cart and email in the form already, and they are not working. Either or. Did you look at the code for that form? They are there. IT's not working for me. What do I do? Days are gone now and my forms are still not working on my LIVE site.

Sign in to reply to this post

deno1965

Add to cart button

The add to cart button was not the problem, it was when I regenerated the code for the form, the extension put the security question code back in the errors and I don't have the security question in the form. Once I removed it from the code in the errors section, the form returned to working.

Sign in to reply to this post

Eric Mittman

My apologies, I misunderstood the situation. When you posted back and said that it is not doing anything I took this to mean that you had not yet applied the server behaviors to the page, this is the reason for my response there.

So the security question was preventing your form from being submitted, I'm glad to hear that you got that issue resolved. Are you still having any trouble with the form and the server behaviors applied to the page? If so please post back with a copy of the page in question so that I can check it out.

Sign in to reply to this post

deno1965

Add to cart

I have my old forms yet that did work with all the server behaviors applied. When I copy and paste them into the new form pages they are starting to work proper now. Just have to readjust some of the css and they will be good. I did something that regenerated the security question and I don't use it, just the captcha. It was'nt in the form, but in the top error code and that's what prevented it from submitting. All's getting there. Thanks

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...