close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

UK Postage with Powerstore 3

Thread began 3/04/2010 10:33 am by Neilious | Last modified 3/17/2010 5:07 pm by Eric Mittman | 1961 views | 14 replies |

Neilious

UK Postage with Powerstore 3

I've been reading through the forum but can't seem to find a solution to this. Powerstore 3 is installed and working but I can't seem to set up a postage rule. I've got ecart 4 installed
I can edit the WA_Store_Cart from the ecart object window and set up a rule called postage.
But when I upload the changed WA_Store_Cart_PHP.php and WA_eCart_Definition_PHP.php to the server I get this error

Parse error: syntax error, unexpected ')' in /web2/user23268/website/WA_eCart/WA_Store_Cart_PHP.php on line 114

but I can't see anything unusual at line 114

Fortunately I've kept a backup of the files so can reinstate them and start the process again.

Basically I want all items to carry a flat rate postage of £1.50 per item with free postage for a cart value of £50 or over.

Thanks for your help
Neil

Sign in to reply to this post

Eric Mittman

You should be able to add the rule to your cart and have it work correctly, how exactly have you configured the charge rule for the postage? The error may be based on one of the values you have used. If you can post back with the cart file that has the error in it as well as some more info about the rule you created I will take a look and try to get yours working for you.

Sign in to reply to this post

Neilious

UK Postage with Powerstore 3

Thanks Eric. Yesterday afternoon I had another look through the forum and noticed that someone else had a similar problem and was advised that it was the existing shipping rules. As I'm not going to be using these I deleted them using eCart and the error

Parse error: syntax error, unexpected ')' in /web2/user23268/website/WA_eCart/WA_Store_Cart_PHP.php on line 114

went away. So I tried using eCart to change the currency, and it worked. I tried using eCart to add a charge this also worked. Then I tried adding a postage rule under the shipping tab of eCart, but it doesn't work. The attached image shows the rule I created also I've attached the WA_Store_Cart_PHP.php file. So a bit of progress but still not there, what am I doing wrong?

Neil

Attached Files
WA_Store_Cart_PHP.php.zip
Sign in to reply to this post

Eric Mittman

I'm glad to hear that you got past the error regarding the built in shipping rule. In the screen shot for your new charge rule in the calculation portion it looks like you are basing the shipping on a particular items quantity.

If you would like to apply a flat rate shipping charge you would just select 'flat rate' from the dropdown and enter the amount. If you wanted it to be based on the total number of items in the cart you can choose 'based on a column subtotal' and select the quantity or any other column that you would like to base the shipping on.

Please post back and let us know how it works for you or if you have any further questions.

Sign in to reply to this post

Neilious

UK Postage not working with Powerstore 3

Hi Eric
Thanks for your reply, but I'm still struggling with this. I followed your instructions using eCart (the attached shows the settings I used) and I uploaded the updated files WA_Store_Cart_PHP.php and WA_eCart_Definition_PHP.php to the
server but when I add a product to the shopping cart shipping doesn't appear at all.

I've no idea what to try next, the couponing system within Powerstore works as does the tax but shipping refuses to appear.

Thanks again for your help on this
Neil

Sign in to reply to this post

Neilious

UK Postage with Powerstore 3

Really need a solution to this problem, my client wants his site to go live and I've no idea of how to fix this shipping issue.

Basically I want to charge £1.50 post and packing per item with free post and pack for orders over a value of £50. I've added a basic rule to ecart and uploaded the files but nothing happens at checkout, what am I doing wrong. I urgently need a solution, please help!!

Sign in to reply to this post

Eric Mittman

To help you determine what is going wrong with these please post back with a copy of your WA_eCart folder from your site root as well as a copy of your cart page in a zip archive. I will use your files to check this out and try to get it going for you.

Sign in to reply to this post

Neilious

UK Postage with Powerstore 3

Hi Eric
Thank you for your reply, I've attached the requested files in a .zip archive. Really appreciate your help on this.

Neil

Attached Files
eCart-and-cart.zip
Sign in to reply to this post

Eric Mittman

The rule looks ok but I can see where you might have a problem. The condition that you have for the rule is if the total number of unique items is greater than 1. The proper condition for this would be if total number of unique items was >= 1. This way even if you have only one item you will be charged. When I set the rule like this it works as expected for me.

One other thing I noticed is that you are charging a flat rate of 1.50 for the shipping, you mentioned that you would like this to be 1.50 for each item unless they purchase 50 worth or more. To make the shipping rule charge like this you should base the calculation portion off the subtotal of the quantity column, times 1.50. To account for totals 50 or more you can add in another condition to the trigger, you would base it off of the cart subtotal being less than 50.

I'm including a total of three screen shots for you on this so that you have a good reference for how these rules should be setup. Let us know if you have any further questions.

Sign in to reply to this post

Neilious

UK Postage not working with Powerstore 3

Thank Eric that's great and makes alot of sense. I've followed your instructions exactly and created a new rule called post and pack. I uploaded the entire WA-eCart directory and tested the site, but when I added a product to the shopping cart, shipping still didn't appear on the cart page. I've attached a screen grab of the settings I used for the post and pack rule in eCart, the cart page, but also the Powerstore Admin settings page. Have I got the shipping settings correct in Powerstore, or do I need to modify something there? I've attached the WA-Globals file aswell in case there's something wrong here.

Thanks for your patience on this I just don't know what I'm doing wrong.

Neil

Attached Files
WA_Globals.zip
WA_eCart.zip
Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...