close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Once wizard has run I can't view my site

Thread began 2/11/2010 9:24 pm by mrs | Last modified 2/17/2010 3:33 pm by Eric Mittman | 808 views | 3 replies |

mrs

Once wizard has run I can't view my site

This is the third time this has happened to me now over the course of two or three years since I bought security assist. Basically, I run the wizard to produce the login pages etc and then without even applying any of the user level access to any of the site, my browser can no longer display the site saying I don't have permission or access.

As far as I am concerned the pages like the home page are unaffected by security assist, and they should be because I need people to view this page in order to log in. No code has been added as far as I am aware to any of the pre-existing pages, so why do I loose the ability to test my site in a browser?

Luckily, from past experience, I backed my site up before running the wizard, so I thought I would copy the back up back on to my PC... problem still occurs... still can't test the site! I do this many times, but to no avail.

In the end, I create a new directory with a different name for my backed up site and copy the files to there. Bingo, it worked straight away. So, what's going on? This happened to me last time where I had to create a new directory with a different name before the site would test again, so what is happening to the permissions of the directory of my site on my PC when I run security assist.

I've been told before on here that it doesn't do anything to my PC, only to the webpages, but that's not right; something is happening that shouldn't be but I don't know what?

I'm not about to repeat the process to replicate the problem as it takes way too long to correct, so I would like some avice on how to prevent this from happening in the future as I am effectively frightened of using this piece of software that I paid good money for.

Your help is going to be very much appreciated here as I have some really big projects coming up that need this kind of funtionality, but, I am too concerned to even consider using it at the moment!

Thanks.

Mat

Sign in to reply to this post

Eric Mittman

Something about what you have stated seems like it might be key to what you are experiencing. You say that you ran the tool, then had the problem. From your experience you knew to revert the site to a backed up copy, but this did not work for you. This tells me that it is not what Security Assist is doing to the page that is the problem since you can revert to the previous versions of these pages and still have the same result.

What exactly is the result that you are getting when you try to access one of these pages? Is it a server error or a 405 type of restriction? Please post back and include any details that you can about the error.

Also, if you could post back with a sample site folder in a zip archive that you are having this problem with it might help to determine what the problem is. What is the web server you are working with?

Sign in to reply to this post

mrs

Sorry for the delay in this Eric. Basically, I haven't done anything apart from run the security assist wizard, so I can't even supply you files to look at. Even if I remove the security assit files that are created, I still can't view the site. It's as though the folder of my website in wwwroot has had access permissions applied to it, but I don't get how or why... security assist should only be affecting the pages it creates, or the pages I choose to apply it to. My understanding was that security assist didn't apply to folders, only html based pages, and it was those pages themselves that determine if a user has access or not.

In this instance, during the process of running the wizard, I get this error on the first page:

The following pages are not based upon your selected template:
Registration is not template based
Profile is not template based
Login is not template based

I can't proceed any further unless I deselect these as options of pages produced by SA, also, choosing another template has no effect on this!!

Anyway, once I have run the wizard, even without applying access rules to any other pages, the whole website (homepage, about us, etc) becomes locked down and this is the error I am getting...

You are not authorized to view this page
You do not have permission to view this directory or page using the credentials you supplied.

--------------------------------------------------------------------------------

Please try the following:

Click the Refresh button to try again with different credentials.
If you believe you should be able to view this directory or page, please contact the Web site administrator by using the e-mail address or phone number listed on the localhost home page.
HTTP 401.3 - Access denied by ACL on resource
Internet Information Services

--------------------------------------------------------------------------------

Technical Information (for support personnel)

More information:
Microsoft Support

I can't even view a brand new blank Untitled.html page created by dreamweaver once this wizard has run. As I have said, if I create a new folder in wwwroot and then copy all the files to that new folder, I am then able to view the site again, so by process of elimination, I would say that the SA wizard is having an effect on the actual site folder!!

My PC is windows XP with DWCS3 and the site is ASP VB with MySQL as a db. I would post a site in a zip file, but it is massive, and as I have said, none of the site has any SA functions applied. The db alone is close to 20 mb.

Hope that helps.

Sign in to reply to this post

Eric Mittman

There are a couple of things here. The first thing is that the error you are getting is coming from your IIS web server. I have seen in the past where problems with IIS can result in this. From my experience it is not an easy thing to deal with and may be a combination of server and permissions settings. Here are a couple links to MS kb articles on this error:

default.aspx?kbid=294382

default.aspx?scid=kb;en-us;317471

There is quite a bit more info out there on the web about this type of error.

It seems that the other problem you are having is using a template with the Security Assist pages. What happens if you do not have a template specified? You should try creating the pages with no template, then applying a template to the pages after the fact if the template is giving you problems.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...