close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Contact From Validation Conflict

Thread began 2/10/2010 8:25 am by tdebos162481 | Last modified 4/06/2010 7:17 am by estherrolle06404909 | 2194 views | 18 replies |

tdebos162481

Contact From Validation Conflict

We have a form prepared using the Contact Form Solution Pack on the following page involve_join_2010.php

We have loaded the WA_Globals.php page in the Contact_2009/WA_Globals directory as well as the WA_Universal_Email and WA_ValidationToolkit files.

The form has embedded Spry validation on form field text and dropdown elements, theses all work. The security image appears, but it does not validate and to form submits even though the text field is blank.

Is there a conflict between the Spry validation and WA security image? This was the only reason I'd purchased the Contact Form so I really need to get it working.

Thanks,

Sign in to reply to this post

neilo

Hi there,

It looks as though not all of the Contact Form Solution Pack files and folders have uploaded to the same directory on your server. Your 'SpryAssets' folder is in the root directory of your site, while the other CFSP folders are in your 'Contact_2009' folder.

Try uploading the 'SpryAssets' folder into your 'Contact_2009' folder along with the other CFSP files and folders. You will need to adjust the paths to these SpryAssets .js and .css files in the head of your involve_join_2010.php page to point to the new location. ( 'SpryAssets/ . . . ' instead of '../SpryAssets/ . . . ')

Sign in to reply to this post

tdebos162481

Hello there and thanks for the pointer...but I am not able to ID the missing files you made reference to. I compared the downloaded zip file and the uploaded files and can not see the ommisions.

The images, fonts and globals, universal email and validation toolkit files/folders are uploaded... The only thing that was not uploaded were the doc and readme files. Can you let me know what you mean by : It looks as though not all of the Contact Form Solution Pack files and folders have uploaded to the same directory on your server.

I've transfered the SpryAssets into the Contact_2009 directory, so everything is contained therein, but the security image verification still does not work.

thanks,

Sign in to reply to this post

neilo

Hi tdebos,

I think I checked that the files required to validate the captcha and send the email were in the correct relative directories as provided in the Contact Form Solution Pack (CFSP) under the assumption that that structure would have remained intact when you transferred the CFSP code to your own template. I'm sorry for any confusion this has led to, but as long as the paths to Spry are correct for your existing fields then all should work.

At the moment your captcha infput field does not appear have a spry textfield id, (id="sprytextfieldX") to tie it to a Spry ValidationTextField Widget in the javascript at the bottom of your page, or indeed a corresponding line in the javascript. Also, there are still a couple of Universal_Email pages missing at the moment if you are going to use the CFSP to send email, or are you sticking with the FormMail script?

I think I an misunderstanding things, I don't want you to be short-changed on support, so I think a WA person needs to look at this.

Sign in to reply to this post

tdebos162481

Thanks for trying to help Neilo. How can I get the help of a WA person?

I tried adding the spy validation to the security image field but it didn't solve the issue.
While the form does not post without a value for the security image, it does submit even if the insertion is false. This is the key problem with the current setup for involve_join_2010.php , how can I get a WA person to resolve the issue?

Thanks

Sign in to reply to this post

neilo

Hi tdebos,

Unfortunately it is a holiday Monday for the WA people, but they will be in tomorrow.

I have been going over your page and can get it to work OK from this end, by re-applying the original Contact Form captcha code and re-adding spry via Dreamweaver.

To test this at your end, could you substitute the attached file for your 'involve_join_2010.php' page and see what results you get.

You will need to make sure that ALL of the Contact Form Solution Pack files have been uploaded 'as is' (apart from the Contactus.php, Contact_styled.php and the help file). You will also need to keep the adjusted WA_Globals.php with your details.

Hopefully this will take you forward a bit. Please post back with your results.

Edit// - This is the test page Feel free to send with filled in and blank fields and correct/incorrect captcha text to test. The form currently doesn't go anywhere.

Attached Files
involve_join_2010.zip
Sign in to reply to this post

Jason ByrnesWebAssist

it's rather difficult to tell what the problem may be without seeing the code.


Please send a copy of the involve_join_2010.php page so I can examine the code on the page.

Sign in to reply to this post

tdebos162481

Thanks for looking into the conflict. Neilo was quite prompt and helpful but I'm still not able to have the form submit with the validation of the catcha image. Once any 5 characters are inputed the form is sent.

I thought the issue may be with the configuration (or lack thereof) of the Universal Email parameters, but in trying to follow the instructions from the readme file, I didn't understand what it meant by "make sure Universal Email is installed". This directory was only a set of php files, so not sure what is meant. Also I WA Server Validations does not appear on the WA server behaviours list.

Attached are all the files that were uploaded pertaining to involve_join_2010.php. Are you able to determine what the issue(s) are?

Thanks

Attached Files
ESCA - Contact_files.zip
Sign in to reply to this post

Jason ByrnesWebAssist

I need to investigate the php code in the involve_join_2010.php page, you did not include that page in the files you sent, please send a copy of the involve_join_2010.php page so I can take a look.

Sign in to reply to this post

tdebos162481

That file is in there, in the main section not a sub directly.
Please have another look through.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...