close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

PEAR

Thread began 3/21/2020 9:25 am by yogastudents362523 | Last modified 3/24/2020 3:26 pm by yogastudents362523 | 119 views | 21 replies

yogastudents362523

Hi

I am now getting a message saying:

"extension missing open ssl"

Thank you,
KB


I have run phpinfo, and openssl is definitely installed.
I have tried all combinations of tls, ssl, starttls, and ports 465 and 587
I get the least number of errors with ssl and 465 and with the following code snipper included (seemed better to put just the one line than attach a page that had my login credentials all over it; am tired and don't want to break anything by editing it out).

I read on a PHPmailer forum that it was advisable to insert the underneath line; and it did seem to reduce errors.

<?php echo (extension_loaded('openssl')?'SSL loaded':'SSL not loaded')."\n"; ?>

I will delete if you advise.

But I believe that that is what tells me that SSL is loaded OK.

Since my php and Apache also seem to have the relevant openssl enabled, I am mystified.

Thank you for your kindness,
KB

UPDATE

I am presently very tired, so it is a job to stay coherent.

I cannot recollect how it happened, but I suddely got refusals to load the Contact Form page I am creating because it was attempting to load:

www.www.xxxxxxxxxx.com

My security certificate (QuickSSL from Geotrust) is in fact for:
only for "xxxxxxxxxx.com", without that "www.".

Therefore, I tried inserting the following code snipper immediately before calling Universal Email, and to strip out that "www.":

<?php
if(!strstr($_SERVER['HTTP_HOST'],'www.'))
return;
header('HTTP/1.1 301 Moved Permanently');
header('Location: http://'.substr($_SERVER['HTTP_HOST'],4).$_SERVER['REQUEST_URI']);
exit();
?>

This garnered a mild success in that the openssl not open error message went away …
however ...

the only thing to be seen in the browser window was the line:

SSL loaded.

Absolutely nothing else was present. At least the openssl not open error had gone.

I therefore tried introducing the following code snipper to reintroduce the "www":

<?php
$url="https://kofibusia.com:8080/href.php?redir=https://www.kofibusia.com";

I now again had a visible contact page, … BUT …

that wretched openssl not loaded error was right back up at the top of the browser window again, although the page with contact form was built.

I am now too tired to mess around with further WebAssist code, but feel that I need to find other instances where this stripping trick might work as the page is being treated.

I perhaps should also try a more efficient method of checking on the "www." code?

I found a snipper from a third party that might provide a test, but it is not wise to do anything else right now.

If you could kindly devote some fresh eyes to this, I would be grateful.

Thank you,
KB

To be clear, I sandwishced UE with code that first stripped the www., and then reintroduced it afterwards. That made the openssl not loaded error disappear, but would not load the page except for the error message at the top saying SSL loaded
Thank you

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...