close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

Creating Data Assist from pages <New From Blank>

Thread began 3/03/2018 12:35 pm by vanroojdotcom | Last modified 3/09/2018 12:53 pm by vanroojdotcom | 91 views | 10 replies

vanroojdotcom

Hi Ray

I've deleted Dreamweaver / re-installed and installed the latest data-assist extension. But the problem has not been resolved, previously when I created a new recordset, I was able to select a database and click TEST and actually see the result of any query. It was only when the recordset was generated that the 406 error code popped up (when selecting the triangle to see the bindings).

Now when I click TEST (in the recordset panel) I get the error "HTTP Error code 500 Internal Server Error". But in the WA Database panel it shows the database and tables so it seems to be seeing the database.

However the pages generated using the Data Assist Pages wizard are working (up to a point), I can select a table and it show the fields, so it is connecting to the database.

EDIT - JUST TO LET YOU KNOW THE ACTUAL PROCESS, WHICH MAY HELP YOU NARROW IT DOWN:

I created a recordset - fine and when it connects I can see all the tables in the database, and the relevant fields. At this point, if I click TEST I get the HTTP Error code 500 Internal Server Error. However, if I ignore the error and just clock OK it will create the recordset. If I click on the expand triangle, it opens up and you can see the Bindings. (It was at this point in the previous version - trying to expand the Recordset that I got the "HTTP Error Code 406 Not Acceptable" error) so that issue has been solved.

So to all intents and purposes (if I hadn't clicked test) everything would look fine. I can drag a binding into the index file - it creates the 'echo' element. Upload the file and you can see the FIRST RECORD of the table.

However, if you try to use Repeat Table or Repeat Region - you still only get the first record showing. It was at this stage that I went back clicked test and got the error. So it maybe that the Repeat element not working is related to the HTTP Error code 500 Internal Server Error.



• Last Version: You could click test and see the result in the window - but you could not see the bindings
• This version: You get an error clicking test - but you can see the bindings (although I can't create a Repeat of more than one result)




Hope this helps you.

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...