close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

spellchecker not showing in editor toolbar

Thread began 3/25/2013 8:07 am by JamieEff | Last modified 4/17/2013 3:36 pm by JamieEff | 2179 views | 29 replies

JamieEff

spellchecker not showing in editor toolbar

Hey Jason

Just wondering why the spellchecker 'abc' icon is not showing in the toolbar even though its specified in the code...

php:
<?php
// The initial value to be displayed in the editor.
$CKEditor_initialValue "".((isset($_GET["invalid"])?ValidatedField("blogupdate","BlogArticle",false):"".$row_WADAblog["BlogArticle"].""))  ."";
$CKEditor = new CKEditor();
$CKEditor->basePath "../webassist/ckeditor/";
$CKEditor_config = array();
$CKEditor_config["wa_preset_name"] = "Normal (custom)";
$CKEditor_config["wa_preset_file"] = "(custom)";
$CKEditor_config["width"] = "514px";
$CKEditor_config["height"] = "350px";
$CKEditor_config["skin"] = "kama";
$CKEditor_config["docType"] = "<" ."!" ."DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01 Transitional//EN\" \"http://www.w3.org/TR/html4/loose.dtd\">";
$CKEditor_config["contentsLanguage"] = "en-uk";
$CKEditor_config["dialog_startupFocusTab"] = false;
$CKEditor_config["fullPage"] = false;
$CKEditor_config["tabSpaces"] = 4;
$CKEditor_config["filebrowserBrowseUrl"] = "../webassist/kfm/index.php?uicolor=".urlencode(isset($CKEditor_config["uiColor"])?str_replace("#","#",$CKEditor_config["uiColor"]):"#eee")."&theme=webassist_v2";
$CKEditor_config["toolbar"] = array(
array( 
'PasteText','-','SpellChecker','Source'),
array( 
'Image','Table','HorizontalRule''SpecialChar'),
array( 
'Link','Unlink'),
(
'/'),
array( 
'Format','Bold','Italic','Underline','-','Subscript','Superscript'),
array( 
'JustifyLeft','JustifyCenter','JustifyRight','JustifyBlock'),
array( 
'NumberedList','BulletedList','-','Outdent','Indent','Blockquote'));
$CKEditor_config["scayt_autoStartup"] = true;
$CKEditor_config["contentsLangDirection"] = "ltr";
$CKEditor_config["entities"] = false;
$CKEditor_config["forcePasteAsPlainText"] = true;
$CKEditor_config["contentsCss"] = array("../css/cms.css");
$CKEditor->editor("BlogArticle"$CKEditor_initialValue$CKEditor_config);
?>



This only seems to be happening when I delete the ckeditor folder and use the folder that replaces it when creating DA pages.

Thanks in advance

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...