close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Permissions and upload folder location

Thread began 2/08/2010 6:26 pm by marek | Last modified 2/09/2010 7:34 pm by Dani Chankhour | 884 views | 3 replies |

marek

Permissions and upload folder location

Hi all-
I did not see anything in the documentation about settings permissions for PowerCMS... Can someone please direct me? I cannot upload or browse images. Why would this not be included in documentation?

Also - how do I change the location of the upload folder? I see in previous posts that the following was available in the WA_globals.php file, but I don't see it...

$WAGLOBAL_Images_Folder = "../image_folder";

Was this setting removed in a recent update? If so, how do I change the folder that PCMS uploads to?

Thanks!
Marek

Sign in to reply to this post

Dani Chankhour

Correct, in the recent update we removed those settings from the WA_Globals. The HTMLEditor will create a files/cms_files folder and it will use that folder to store your images, but if you wanted to update that, open your cofiguration.php file which is located under HTMLEditor/editor/plugins/kfm/ and change those two settings to the folder you want to upload to:

$kfm_userfiles_address = '../../../../files';

$kfm_userfiles_output = 'files/';


In addition if use the upload tab in the image upload, you also need to change the config.php which is located under HTMLEditor/editor/filemanager/connector/php and change this setting:

$Config['UserFilesPath'] = 'files/' ;

to match where you want the files to be uploaded.

Sign in to reply to this post

marek

Thanks Dani.

How about permissions? Because PowerCMS is creating a folder I assume that 777 needs to be set on the entire "CMS folder? That of course opens up a huge security hole. So is there another way around it? Maybe I could create the "cms_files" folder for PowerCMS and only set write settings on that folder? (to avoid giving write settings to the entire CMS folder)

Please explain how we can allow uploads and browsing, but at the same time minimize security issues.

Marek

Sign in to reply to this post

Dani Chankhour

Yeah, in your CMS folder create a folder and call it "files" and give that folder 777 permissions. This should resolve the permission issue. If you are still getting the issue, try creating another folder inside the files folder and call it "cms_files" and give it the same permissions.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...