close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

WA_SecurityAssist/WA_RandomPassword.php error

Thread began 5/09/2009 11:58 am by christerfredrickson378535 | Last modified 4/13/2010 2:27 pm by Andrew Read | 2901 views | 10 replies |

christerfredrickson378535

WA_SecurityAssist/WA_RandomPassword.php error

Hello Folks,

I need help please with an error. I did the set-up solution 3 times to the T and still get this error when I try to login:

Warning: require_once(WA_SecurityAssist/WA_RandomPassword.php) [function.require-once]: failed to open stream: No such file or directory in /home/content/m/a/r/marla007/html/signup_EmailPW.php on line 3

Fatal error: require_once() [function.require]: Failed opening required 'WA_SecurityAssist/WA_RandomPassword.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/m/a/r/marla007/html/signup_EmailPW.php on line 3

Anyone have any ideas? I thank you in advance.

Sign in to reply to this post

Ray BorduinWebAssist

It means the file referenced wasn't uploaded to the server:

WA_SecurityAssist/WA_RandomPassword.php

Make sure that file exists and is uploaded and the error should go away.

Sign in to reply to this post

christerfredrickson378535

Yup, I sent in a ticket and they told me this was a common error and sent me the files to put them in manually.

Now, when I login (with correct login info) I get sent to the forgot email page and I'm asked for me email so that I may be sent a new password. After submitting my email I still do not get an email.

Any ideas why?

Thanks for your time,

Christer

Sign in to reply to this post

Ray BorduinWebAssist

Spam blocking is a likely culprit if you have no errors.

Sign in to reply to this post

paul377172

I'm getting the same problem with the asp version. The include files aren't being generated.

<!--#include file="../WA_SecurityAssist/WA_SHA1Encryption_vb.asp" -->
<!--#include file="../WA_SecurityAssist/WA_RandomPassword_vb.asp"-->


The error on the webpage

is Active Server Pages error 'ASP 0126'

Include file not found

/manageproducts/users_Registration.asp, line 2

The include file '../WA_SecurityAssist/WA_SHA1Encryption_vb.asp' was not found.

Sign in to reply to this post

Ray BorduinWebAssist

You can search your computer for those files and copy them to the correct location manually.

Another option is to add a binding to a page using the random password and encryption formats. It should move those files to the correct location whenever the binding is used, it may not have worked when you applied it for some reason... did you use the bindings panel?

You can either find and move the files manually or try using the binding a couple of times and hopefully it will work.

Sign in to reply to this post

paul377172

Thanks I put the support ticket in and they sent me the files. Having read one of your other threads I wanted to have an email sent to the person who registers and for them to activate by clicking on a link in the email. I figured you needed to use securityassist to create a random password and use dataassist to store that password using insert record, but my problem is that I can't seem to get universal email to work with the registration page created by security assist. I've tried using both asp mail and asp email and its not a spam thing because I've it with data assists forms and forms created with dreamweaver and they all work with universal email. Is there any reason why its not working with security assist registration form. I thought it might be form action but when i left it blank it still didn't send.

Thank you

Sign in to reply to this post

paul377172

Its ok I sorted that out by putting the UE code at the top of the page

Sign in to reply to this post

Andrew Read

This is yet another "known issue" that should be put into the known issues folders...! Along with the required files.

These files were put into the completley wrong folder by Security Assist...

When will this be fixed?

Sign in to reply to this post

Ray BorduinWebAssist

Any issues found in Security Assist will be fixed in the next update. What is the exact issue you ran into, I'll make sure it was logged as a bug and can be addressed.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...