close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Menu Crashes with Sound Manager 2

Thread began 1/28/2010 8:48 pm by inti269116 | Last modified 1/29/2010 11:36 am by neilo | 1040 views | 6 replies |

inti269116

Menu Crashes with Sound Manager 2

Hi there I'm using sound manager 2.0 to play some mp3s in one of my pages, and it's causing the navigation created with css menu writer to stop working only on IE... it works perfectly on every other browser, even iphone . here's the page:
musicProduction/

can you help me with this?

thanks!

Sign in to reply to this post

Dani Chankhour

Nothing is showing for when i go to your page in FF or IE.

I just want to mention that it seems that you don't have some of the CSS Menu Writer files on your server, please Upload your CSSMenuWriter to the server.

Sign in to reply to this post

neilo

Your musicProduction Page currently calls cssmw1

menu.php

Looking like this:

<ul class="level-0" id="cssmw1">
<li><a href="/~Inti/Inti Site/home/index.php">HOME</a></li>
<li class="parent"><a href="/~Inti/Inti Site/services/index.php">SERVICES</a>
<ul class="level-1">
<li><a href="/~Inti/Inti Site/musicProduction/index.php">Music Production</a></li>
<li><a href="/~Inti/Inti Site/webDesign/index.php">Web Design</a></li>
<li><a href="/~Inti/Inti Site/Templates/liveSound.html">Live Sound</a></li>
</ul>
</li>
<li class="parent"><a href="/~Inti/Inti Site/media.html">MEDIA</a>
<ul class="level-1">
<li><a href="/~Inti/Inti Site/Templates/photos.html">Photos</a></li>
<li><a href="/~Inti/Inti Site/Templates/videos.html">Videos</a></li>
</ul>
</li>
<li><a href="/~Inti/Inti Site/Templates/clients.html">CLIENTS</a></li>
<li><a href="/~Inti/Inti Site/Templates/about.html">ABOUT</a></li>
<li><a href="/~Inti/Inti Site/Templates/blog.html">BLOG</a></li>
<li><a href="/~Inti/Inti Site/Templates/contact.html">CONTACT</a></li>
</ul>

<script type="text/javascript">if(window.attachEvent) { window.attachEvent("onload", function() { cssmw1.intializeMenu('cssmw1',{select_current: 0, orientation: 1}); }); } else if(window.addEventListener) { window.addEventListener("load", function() { cssmw1.intializeMenu('cssmw1',{select_current: 0, orientation: 1}); }, true); }</script>
Sign in to reply to this post

inti269116

upps! I was working on it

Its ok now I was just working on it when you looked..! wasn't expecting such a quick response!

thanks... I still have the same problem with IE...

Sign in to reply to this post

neilo

Hi,

How is it going? It all checks out OK at this end in IE8 and 7 - I'm not able to check IE6 at the moment except through Adobe's Browser Labs which shows a couple of layout differences and the menu css doesn't seem to be connecting, but I'm not sure if I'm seeing an accurate rendering by Browser Labs.

Sign in to reply to this post

inti269116

Hey Neilo!

Thanks for checking!
Yeah I'm just not designing for IE6 any more...! but what actually happens at my end is that when I visit the page with sound manager (Music Production) the links in the menu for some estrange reason stop working... meaning clicking does not takes you any where.

This only happens in IE 7 and IE8 in my computer (haven't check IE6)... everywhere else in Mac and even in Safari and FF for PC it's fine....

I know its interaction with Sound Manager 2.0 what's causing this. I commented that div out and ran some tests and it was fine after that...

I had checked in at least 4 different PC computers so far with the same results..

please let me know if you find a way around this....

Sign in to reply to this post

neilo

Hiya,

In IE7 on two different machines, - one XP, and the other Vista, the following happens for me:

If I freshly load or reload the page into musicProduction/index.php I can click on the 'Services', 'Web Design', and 'Home' links, and the menu works just fine. If, from any of these pages, I click on the 'Music Production' link, it will open that page, but from then on the menu doesn't function for any page.

This is odd, as I would assume that the menu and other page elements in the musicProduction/index.php page should exhibit the same behaviour whether it is from a freshly loaded page, or from the page as arrived at from by clicking the musicProduction links (on any page). Same page, but two different behaviours.

In IE8, the links don't seem to work whether in a freshly loaded page or whether it is arrived at through any of the links.

This by way of information, nothing practical, but will have another look.

Sign in to reply to this post

neilo

This post has been deleted.

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...