close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Power CMS

Thread began 1/20/2010 2:50 pm by christine310921 | Last modified 1/20/2010 7:58 pm by shadow329043 | 1116 views | 6 replies |

christine310921

Power CMS

I have uploaded my files to my website and when I login to the admin it says no database selected. I have configured the localhost.php in Dreamweaver and it connects okay. I have also set up the database in PHPMyAdmin on my host. Can someone tell me why I am getting this message.

Sign in to reply to this post

shadow329043

Did you do the sql import to set up the database? - it is in the database folder. Here are the instructions importing_sql.pdf

Sign in to reply to this post

christine310921

No database selected

I have configured the localhost.php as instructed. Tested it in Dreamweaver and it is okay. I have PHPMyAdmin on my local host and imported the SQL file into a database I created using the same database name. I then set up a User and Password identical on the remote host. Any other ideas?

Sign in to reply to this post

neilo

"I then set up a User and Password identical on the remote host."

If you began ny setting up the database on your local computer, I don't understand how you can then set up a user and password 'identical' on your remote server?

Did you use your remote hosting username and password when you installed mysql on your machine? I use IIS - so I'm unfamiliar with how other server models are configured for testing purposes.

It is often the case that your mysql login and username is partially set from (prefixed by) your Hosting account username.

so my local connection is

$hostname_mymachine = "localhost";
$database_mymachine = "cms";
$username_mymachine = "root";
$password_mymachine = "XXXXXXXX";


whereas my hosted mysql is

$hostname_localhost = "www.pictuality.co.uk"; (or localhost)
$database_localhost = "uks6XXX6cms";
$username_localhost = "uks6XXX6nh";
$password_localhost = "XXXXXXXX";

[uks6XXX6 being my host-assigned prefix]

Sign in to reply to this post

shadow329043

I am familar with both IIS and MySQL and you have to set up a database user and password on a remote data table before you can access it........and it is that information that you put into the localhost file.....while you are on your remote data table, you should import the sql file and create the necessary data structure.

Sign in to reply to this post

christine310921

Everything is working now

Hi everyone,

Thanks for all your input. I understood what you posted but had done everything as you had described. Because of this I thought I would just delete the database on the remote server and re-install it with the same settings. This time it worked!!!

Thanks for all your help.

Sign in to reply to this post

shadow329043

glad to hear it - it is always best just to delete and reinstall

Shadow

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...