close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

How do I putenv

Thread began 1/08/2010 10:48 am by woodenboat | Last modified 1/15/2010 1:46 pm by woodenboat | 1030 views | 5 replies |

woodenboat

How do I putenv

I'll try and explain something I've had very little experience with...

The problem is a godaddy server. Because we are using Gmail for our domain email all the mail that leaves our server is from anonymous@servername.com. I need to be able to force the emails to have an envelop or something like this so the emails are not coming from anonymous@servername.com, but instead from me@domainname.com.

I have changed other forms that are now working using lines like:
'putenv('MAILUSER=mail@address.com');

I'm assuming I can add a line to mail_PHP.php file but I don't know where to put it and how it should be written.

I have waglobal set to: $WAGLOBAL_Email_Server = "" ;

Leaving the godaddy server is not an option right now. Godaddy’s network spam filter bounces all email coming from anonymous.

Help!

Sign in to reply to this post

Jason ByrnesWebAssist

in the WA_Globals file set the from address:
$WAGLOBAL_Verification_Email_FROM


to the email address you want displayed:
$WAGLOBAL_Verification_Email_FROM = "me@mydomain.com";

Sign in to reply to this post

woodenboat

Thanks but I have that setting already.
The problem is the qmail environment puts in anonymous and the email gets bounced.

Like I said > I have fixed this with other php forms by adding something like
$MPForceSender = 'mail@address.com'; or
putenv('MAILUSER=mail@address.com');
in the file php file that processes the form.

If/when I find a solution I'll post back unless you can think of something else to try.

Sign in to reply to this post

Jason ByrnesWebAssist

Can you send an example script where you have used this so I can see it in context?

Sign in to reply to this post

woodenboat

problem solved

there were two changes made to make it work on this dedicated godaddy server which uses qmail.

The first was my mistake, I forgot to turn off php safe mode.

The second change was in the in the WA_Globals where I added one line at the top:

<?php
putenv ("MAILUSER=noreply@mydomain.com");

Sign in to reply to this post

woodenboat

hope this helps

if someone else runs into the same issue on a dedicated godaddy server and where the domain email is hosted somewhere else.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...