close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues


Product Image Upload Not Working

Thread began 1/05/2010 12:40 am by Nigel | Last modified 1/05/2010 1:41 pm by Nigel | 1052 views | 4 replies |


Product Image Upload Not Working

Upload works if I try with a 60kb file, but when I'm uploading a product image 1,800 kb I get:

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 14592 bytes) in /home3/livewel2/public_html/WA_DigitalFilePro/HelperPHP.php on line 844

I've upped all the relevant config settings that I've found in php.ini to no avail, including:

upload_max_filesize = 60M
post_max_size = 60M
max_execution_time = 120
max_input_time = 120
memory_limit = 120M

I have GD 2.2.1 installed.

Any ideas?

Sign in to reply to this post

Jason ByrnesWebAssist

The error indicates that the memory_limit is set to low.

increase the memory_limit to 256M:
memory_limit = 256M

Sign in to reply to this post


Same Error

Thanks for the reply Jason. I tried that and still get the same error. PHP settings:


I think PowerStore came with DFP1, should I try update it with DFP2 or will that get messy? Advantage of DFP is auto thumbnail.

Thanks for your help.

Sign in to reply to this post

Jason ByrnesWebAssist

no,Power Store comes with DFP 2 already. The problem occurs when trying to re size the image, image re size was not available ion DFP 1.

Looking at the error, I dont think the memory limit settings are being increased. The first part of the error is reporting the memory_limit in bytes:

  Allowed memory size of 33554432 bytes exhausted  

33554432 bytes = 32 Megabytes

lets try setting the memory limit using the ini_set command. add the following at line 1:


to check that the memory limit is being changed, add the following after the <body> tag:

Memory Limit:<?php echo(ini_get('memory_limit')); ?>
Sign in to reply to this post



Thanks Jason. You were right, the limits were not being raised. Although I changed the settings on the php.ini in the public_html directory, these were not getting applied to the Admin sub directory. I copied the php.ini there and it seems to be working. I thought the php.ini in the root would automatically get applied to sub directories but it seems to depend on the way the server is configured (HostMonster) and my config requires the php.ini be applied to all sub directories.

Thanks again for the solution and the quick response.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question





Ease of use


security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...