close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Parse Error?

Thread began 12/26/2009 3:02 pm by elevy388997 | Last modified 12/29/2009 6:56 pm by Eric Mittman | 1740 views | 12 replies |

elevy388997Beta Tester

Parse Error?

I am getting this error and have no clue how to get this form working:

Parse error: syntax error, unexpected ')' in C:\Inetpub\vhosts\secure.embforum.com\httpdocs\Contactus.php on line 123



Line 122 - 125:

if (ValidatedField('contactus','contactus')) {
if () {
if (!(false)) {
?>



If you need more information, please let me know as I don't really know what is causing this.

Sign in to reply to this post

neilo

It is expecting some conditions to appear before the second (closing) bracket of the 'if' statement.

The 'out-of-the-box' code that would normally be here for the contactus.php form page is:

<?php
if (ValidatedField("contact","contact")) {
if ((strpos((",".ValidatedField("contact","contact").","), "," . "5" . ",") !== false || "5" == "")) {
if (!(false)) {
?>
Sign in to reply to this post

Office Guy-172461

Have a look here:
6.php

I have no idea what you are trying to accomplish with those lines.

Sign in to reply to this post

elevy388997Beta Tester

Ok I got the form to show up and it is able to be filled out correctly (dynamic items work), but when you click submit, it just resets the form and doesn't do anything.

And it is a submit button, not a reset button. I am using the DigitalGoodsCheckout form in this case.

Sign in to reply to this post

elevy388997Beta Tester

So I figured I would start over and see if I could figure it out and 2 things are happening.

The first time I used the normal smtp settings for the mail server in universal email, and everything would work out fine until you hit the submit button. It would just "flash" the internet page quickly then all the text would be gone, so it was empty text fields again, and no email would be sent and it wouldn't go to the "thankyou.php" page.


The second time I figured I needed to authenticate the mail server so I choose the PEAR option in universal email. Now when you hit submit it gives this :


Warning: waue_sendmail(Mail.php) [function.waue-sendmail]: failed to open stream: No such file or directory in C:\Inetpub\vhosts\secure.embforum.com\httpdocs\WA_Universal_Email\PEAR_Mail_using_SMTP_PHP.php on line 115

Fatal error: waue_sendmail() [function.require]: Failed opening required 'Mail.php' (include_path='.;./includes;./pear') in C:\Inetpub\vhosts\secure.embforum.com\httpdocs\WA_Universal_Email\PEAR_Mail_using_SMTP_PHP.php on line 115


So I went to that file and this is line 111-123:

function WAUE_SendMail($mailObj,$mailAttachments,$mailBCC,$mailCC,$mailTo,$mailImportance,$mailFrom,$mailSubject,$mailBody) {
if (strpos($mailTo,"@") < 0 || sizeof($mailObj->recipients) == 0) {
return;
}
require_once($mailObj->PearPath."Mail.php");
$paramArray = array();
$headerArray = array();
$headerArray["MIME-Version"] = "1.0";
$fromArray = WA_getEmailArray($mailFrom);
$mailFrom = $fromArray[0][1];
if ($fromArray[0][0] != "") {
$mailFrom = $fromArray[0][0]." <".$fromArray[0][1].">";
}


Any solutions? I tried the help files and search function. I did notice though with the first method, there was a "Mail.php" and for the second one it doesn't create it.

Thanks

Sign in to reply to this post

elevy388997Beta Tester

I couldn't figure out what was going on so I deleted the local and remote files and tried the contact form solution pack...and it worked. But I would like to use the FB since I like it much better and should have been able to make a form just like the CFSP. I am going to try and redo the form various ways and post my results.

Ok now I am getting a new error:

Error generating form:
TypeError: this.ThemeArray has no properties

then I click ok and get this:

While executing timer in WA_SiteTools_Progress.htm, the following Javascript error occurred:
At line 215 of "C:\Program Files\Adobe\Adobe Dreamweaver CS4\Configuration\Floaters\WA_Progress\WA_ProcessingObjects.js": wa.generate.themeArray has no properties.

Sign in to reply to this post

Office Guy-172461

Try step 1:

146/

Sign in to reply to this post

elevy388997Beta Tester

Thank You, I cleared the cache reinstalled the extensions, cleared it again, and it is working.

I have a new question.

When I am adding additional fields to the form, I have it as two separate "sets" on the same "line". So it should have the two fields on the same line. In the form preview it DOES but when it goes live, it DOESN'T. I tried changing the form width via "Edit Design", and it gets wider but it still puts the two fields on top of each other.

Sign in to reply to this post

Eric Mittman

You should edit the form with the edit contents and select the set you want to be on the same line, make sure that you have the box checked that says 'continue on same line as group above'. This should ensure that you have the input on the same line rather that on it's own.

Sign in to reply to this post

elevy388997Beta Tester

When you go to the sets, there is no continue on same line as above. In the content editor it shows up correctly (1.gif), but when I upload it live, it turns out differently (2.gif). See attachments.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...