close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Multiple problems: Permissions, "No images" error, more

Thread began 11/30/2009 12:48 pm by AdamG | Last modified 12/03/2009 5:27 pm by Justin Nemeth | 1401 views | 8 replies |

AdamG

Multiple problems: Permissions, "No images" error, more

So I'm just getting started with Power Gallery. Here are some of the issues:

Uploaded all files to the web server.
Navigated to the Power Gallery files, and started up the wizard.
Wizard creates a file called "Connections" but sets up the folder without write permission. It also sets up the folder with incorrect ownership (User: apache; Group: apache). Should be User/group for my server.

I therefore had no access to "Connections". Couldn't delete it, etc.

Workaround: Had to call my webhost to delete the folder and re-create it.

All fine, at this point (except I need to know what I did wrong, or if your software isn't working correctly).

Now, I'm trying to include the images that are provided as samples, but Power Gallery is reports "ERROR: The image folder contains no images! Please choose another folder." The images are definitely in the folder... I can see them in the Power Gallery Admin system.

Your help will be appreciated.

Permissions problems persist. The folder called "images" which was created when I tried to import the sample images has the same incorrect permissions as the "Connections" file. I can't access the folder, so I think I'm going to have more problems.

Need some help, guys.

Sign in to reply to this post

Justin Nemeth

The directories should have been created with permissions allowing writing, but its possible your server is setup in a way that is not creating them how we expect. You can try modfying a few lines of code that should hopefuly fix the issue.

Anywhere a mkdir is called, try adding , 0777 to that line. For example, instead of mkdir('../Connections/'); use mkdir('../Connections/', 0777);

There are several files that will need this changed. If you can do a search in Dreamweaver for mkdir, you can modify each of those lines. I am not exactly sure why its not working for you out of the box, but try making these changes and see if it helps.

For now, you could just update the install files first and see if that allows it to work.

-justin

Sign in to reply to this post

Office Guy-172461

This might help you find them:

Find all instances of a variable in a site
185/

Sign in to reply to this post

AdamG

Permissions problems persist

Permissions problems persist.

Made changes to "mkdir" as instructed and uploaded all files again.

PowerGallery folder, with all files inside, uploads with permissions: rwx r-x r-x

I changed these permissions to rwx rwx rwx but I'm getting another permissions error, right at Step 1:
"Files and directories cannot be created. Verify your powergallery directory has write permissions." But as mentioned, I had already changed the permissions to rwx-rwx-rwx.

So I'm unable to test if the mkdir solution works.

Very frustrating. I don't know if this is a problem with my webhost or with WebAssist software.

Any further suggestions? Can I get on the phone with someone at WebAssist?

Sign in to reply to this post

Justin Nemeth

Hmm, yeah it sounds like something with your web host is different for some reason. This is the first I've heard of permissions issues like this. We obviously try to account for everything as best we can, but with so many web hosts out there there is still the potential for issues. I will talk to a few folks here and see what the best way to proceed is.

-justin

Sign in to reply to this post

AdamG

Webhost info

Was on with my webhost. They told me to tell you that they use the Plesk control panel system on the Centos (Linux) operating system.

I've had them delete all PowerGallery folders (since I didn't have the correct permissions). Before I try again, I'll wait for your next reply.

Thanks.

Sign in to reply to this post

AdamG

Still having permissions problems.

Is this problem being looked at?

Sign in to reply to this post

Jason ByrnesWebAssist

I have created a support ticket so we can look into the issue with you.


to view and edit your support ticket, please log into your support history:
supporthistory.php?

Sign in to reply to this post

Justin Nemeth

FYI for others experiencing permissions issues like this. Make sure safe mode is off in your PHP settings. Your hosting provider can help you out with turning that setting off.

-justin

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...