close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Problem getting USPS Shipping working with eCart 4.1.6

Thread began 4/27/2009 3:53 pm by chestnut106691 | Last modified 4/28/2009 3:16 pm by Ray Borduin | 1586 views | 5 replies |

chestnut106691

Problem getting USPS Shipping working with eCart 4.1.6

I am running into the following error message.

--------------------
Shipping Quote Failed
We're sorry
No Packages to Ship
--------------------

I'm assuming that something dealing with the 'weight' or 'totalweight' value is wrong somewhere, but I've tried everything. I'm trying to use the USPS connection. The connection seems to work, but the eCart values being passed to it seem incorrect. I'm using their test values for ToZip(20008), FromZip(10022), and Weight(2).

Again, I believe the weight value is an issue. I've tried every possible combination and I'm getting 1 of the 2 error mssg below:

Shipping_SubPackage.WeightUnits = "lb"
Shipping_SubPackage.PackageWeight = 2
Error Mssg is: "Please enter a valid weight in pounds. "
------------------
Shipping_SubPackage.WeightUnits = "lb"
Shipping_SubPackage.PackageWeight = "(2)"
Error Mssg is: "No Packages to Ship"
------------------

Any assistance would be great!

Sign in to reply to this post

Ray BorduinWebAssist

I would try using the live server instead of test mode. It looks to me like you would need something 10 lbs 5 oz for it to work in test mode.

Sign in to reply to this post

chestnut106691

Hi Ray,

I just switched over to the production server and still the same message. I have the error message kicking back, but still a no go. Here's what comes up. I'm now concerned that nothing is being sent from my side as the 'full request' line is empty???

Shipping Quote Failed

We're sorry

Quote: 0
Success: False
RespCode: 0
ErrCode: 0
ErrDesc No Packages to Ship
Full Request:
Full Response:


What do I need to send you in order to get a resolution? I tried searching the forum, but didn't find anyone else with the similar problem...help?

Sign in to reply to this post

Ray BorduinWebAssist

It sounds like you may have zero weights for the items in your cart or no items in your cart at all during the checkout. Make sure you have items in your cart and those items have a weight specified.

It will work if configured properly, so something is wrong witht the implementation. The no packages to ship error will occur when your cart is empty or when the total weight in the cart is zero.

Sign in to reply to this post

chestnut106691

Hi Ray,

OK, I think I'm getting somewhere....I've given up on the USPS issue, and will tackle that issue at a later time (went ahead and purchased a third-party plug-in, and works). However, now I'm getting the following message when processing the checkout page:

-------------------
Status:
Error Code: 10501
Severity Code: Error
Short Err Mssg: Invalid Configuration
Long Err Mssg: This transaction cannot be processed due to an invalid merchant configuration.
CorreID: e2a33ad3b1be8
Timestamp: 2009-04-28T18:36:04Z
Amount: 838.75
AVS Code:
CVV2 Code:
TransID:
Full Request: <developertestaccount><developerpsswd><developersignature>2.20Sale838.7517.5075071.25WebAssist.eCartASP.Pro.DP30AK-Contracts50130AK-Torts544120CA-Cal Essay Package65Visa4169510120000580042019verifiedIanChestnutsuppor_1240834701_per@ivcpro.comUS
88282 Someplace St.Los AngelesCAUSUS90089832-563-0905
123128.125.52.145911024336

Full Response: <developersignature>2009-04-28T18:36:04ZFailuree2a33ad3b1be8Invalid ConfigurationThis transaction cannot be processed due to an invalid merchant configuration.10501Error2.20892334838.75
--------------------------

Do you see anything in here that will help point me in the right direction?

Ian

Sign in to reply to this post

Ray BorduinWebAssist

"This transaction cannot be processed due to an invalid merchant configuration"

means it is a problem with your profile with your payment gateway. you will probably have to contact them to find out what the issue is.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...