close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Top Navigation disappears

Thread began 11/22/2009 4:16 am by PeterL | Last modified 11/30/2009 7:19 pm by Eric Mittman | 1358 views | 5 replies |

PeterL

Top Navigation disappears

Hello,

i have made a CSS Sculptor layout and in the preset manager i have checked layout components > TopNavigation. I have saved the layout and imported it in Siteasssit pro.
When the site is build the TopNavigatio disappeared an everything looks messed up.
(i have added a picture)

Why this happens?

Peter

Sign in to reply to this post

Eric Mittman

What is the CSS Sculptor Preset that you choose originally? Please post back with this info and also some info about the steps you took to implement the layout.

I did a test like you described of checking the top navigation box in the interface, I then saved this preset as new Sculptor layout.

Once saved I used the preset manager to create a new SiteAssist Pro preset, I choose the sculptor preset that I had just created and also a menu that I had created. I put the menu in this top navigation section and just set the other areas accordingly.

When I generated a new site based on this I was able to see the navigation just where I had specified within the top navigation area.

Sign in to reply to this post

PeterL

Originally Said By: Eric Mittman
  What is the CSS Sculptor Preset that you choose originally? Please post back with this info and also some info about the steps you took to implement the layout.

I did a test like you described of checking the top navigation box in the interface, I then saved this preset as new Sculptor layout.

Once saved I used the preset manager to create a new SiteAssist Pro preset, I choose the sculptor preset that I had just created and also a menu that I had created. I put the menu in this top navigation section and just set the other areas accordingly.

When I generated a new site based on this I was able to see the navigation just where I had specified within the top navigation area.  


i have chosen 3 column, fixed header and footer
I have changed the pagewidth to 900 pix, checked the 'topnavigation check' and inserted a menu with Menuwrighter.
After all this i have saved the page as a dreamweaver_template. Than from the preset manager i have chosen 'new' and checked the dreamweaver template i just created. further i have chosen in the presetmanager in the poduct-tab Siteassistpro layouts. Than i have passed through the 4 steps (in my case step 3 and 4 are exactly the same as 1 and 2 so that makes no sence to me)
When i do not check teh topnavigation check and create my own navigationdiv the problem does not appear.
Important: i work on a Mac

Eric, im my opinion there is no clear description or any other solutionrecipe that explanes this matter systematic. (i mean how to use the presetmanager to handle sclulptor laypouts or DWT's) When i am wrong please tell me where i can find this.

Peter

Sign in to reply to this post

Eric Mittman

I think that the problem you are experiencing may be due to the way you are crafting the template to include as your SiteAssist layout. Instead of adding in the menu to the template you should just save the page as a template and create a new SiteAssist layout based on this template minus the menu. You can also use the CSS Sculptor preset directly without making a template from it first, you just select the CSS Sculptor preset that you created. There is more info on creating the SiteAssist Pro layouts with CSS Sculptor and Menu Writer in this document that can be found on the SiteAssist Pro page under the FAQ:

siteassistpro_update_sculptor_mw_ht.pdf

Also, for the screens that seem the same the first set is for the home page and the next set is for the content pages in case you would like them to look different. If not you would do the same steps for both sets of pages.

Sign in to reply to this post

PeterL

Eric,

i did some practice and i think i get it.......
Thanks again!

Peter

Sign in to reply to this post

Eric Mittman

Glad to hear that, let us know if you have any further troubles with any of this.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...