close ad
Databridge V2 with MySQLi support IS Now Available!
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Help... DFP Update not working

Thread began 11/10/2009 11:57 am by mrs | Last modified 11/12/2009 7:40 pm by Dani Chankhour | 3612 views | 11 replies |

mrs

Help... DFP Update not working

I have been trying this now for a good four or five hours, and I can't get it to work. I used to be able to do it fine in DFP1, but I am using version 2 now and the online videos don't match version 2, even though I have managed to figure out the differences... or at least I think I have.

I have entered content into the db via the insert, the image has uploaded and is displaying great from the insert page.

It is also working great from the update page if I want to update the image... however, the problem is that if I just want to update text and NOT the image, the data that is already in the update field is not being passed over as default and deleting the info for the image that is already there.

In the DFP panel, I have set...
File field: imagenameFile
Default file: imagename (from the Update Form info which is the hidden field)
Upload: images/stock/
File name: [Filename]

In the Update Record behaviour from the server behaviours panel I have set...
Select imagename in list
Click lightning bolt
Choose Server File Name from Upload File

The code for the page is attached.

Thanks.

Attached Files
DFP2 problem.txt
Sign in to reply to this post

Dani Chankhour

What version of Digital File Pro are you using?

Our latest dot release should have fixed this issue.

Sign in to reply to this post

mrs

I'm using 2.0.2 which if my downloads area is correct is the latest download available. Well, it's kind of a comfort that I am using the tool correctly, but I've still wasted over five hours of my day trying again and again to get it to work!

Is what I have done correct?

Is 2.0.2 the latest release?

In the code I have posted, what can I put right to ensure it is corrected? Have you looked at the code to see if I have been using the tool correctly?

Sign in to reply to this post

contact318852

update record deletes other columns

I was just about to post a thread about this issue as well and saw this so I am tagging my issue here too.

I have DigitalFilePro 2.02 and can update a record, and get filename in database, however if I return to the update form and leave some of the fields blank, it will erase any entry in the database that wasn't updated with a file.

some specs digitialfilepro 2.02
dreamweaver cs3
windows vista home premium
64 bit

Sign in to reply to this post

anonymous

contact,

It sounds like you need to populate your form fields on your update page with the existing values in the database... that way, regardless of whether you edit them or not, the original value is submitted. if you have any questions how to do this, just drop a line here.

Best regards,

Brian

Sign in to reply to this post

contact318852

update

thanks for the prompt reply,

I thought my hidden field was doing that, is this enough code for you to determine if I have entered it correctly? - following the tutorial...

Ive added more code sample here..


// WA_UploadResult1 Params Start
$WA_UploadResult1_Params = array();
// WA_UploadResult1_1 Start
$WA_UploadResult1_Params["WA_UploadResult1_1"] = array(
'UploadFolder' => "images/profile",
'FileName' => "images/profile/".$_SESSION['MemberID'] ."_avatar",
'DefaultFileName' => "".$WA_DFP_UploadStatus["WA_UploadResult1"]["serverFileName"] ."",
'ResizeType' => "2",
'ResizeWidth' => "120",
'ResizeHeight' => "120",
'ResizeFillColor' => "#FFFFFF" );
// WA_UploadResult1_1 End
// WA_UploadResult1 Params End?>

<tr>

<td class="WADADataTableCell"><input type="hidden" name="AvatarFileName" id="AvatarFileName" value="<?php echo(str_replace('"', '&quot;', $row_WADAmember['AvatarFileName'])); ?>" size="32" />
<input type="file" name="AvatarFileNameUPD" id="AvatarFileNameUPD" /></td>

</tr>

Edit> As I explore this more I realize this is strange, some fields seem to work ok and do not get deleted on a new update, others do not. I have manually edited the code to read the existing values, but some fields wont let the edits 'stick' if i go back into the WA Upload files wizzard it occaisionally looses the 'default filename' code.



I hve moved my question to this thread showthread.php?p=29174#post29174

Sign in to reply to this post

anonymous

One thing I noticed is that you have your DFP files flipped... the file you are uploading - meaning $WA_DFP_UploadStatus["WA_UploadResult1"]["serverFileName"] should be in the File Name of the DFP since that is the one that is actually being uploaded or changed. The Default file name is used to specify the image that will be used (typically the previous one uploaded) in the case that there is no image uploaded on the update page. To code this correctly, you should actually store the recordset value from the image field into a hidden field on your form... then inside the DFP dialog box, you would set the Default File to the hidden form field containing your image value from the original recordset.

Also, with the rest of your fields on the form, be sure that you are actually just populating the input fields themselves... you shouldn't need to use hidden fields for the non-image or non-file upload fields.

Regards,

Brian

Sign in to reply to this post

mrs

Brian, who was that reply to?

As far as I am aware I posted a request for help and I haven't seen anything that is helping me!

When I do an update, the fields, radio buttons, menus etc whatever they be are populated correctly. I have even tested the page before turning the text field into a hidden field and it is getting populated...

So, on that basis, when I turn the text field to a hidden field, it should be getting db info, but it is in the process of submitting that the hidden form content is being erased and is giving me a blank db field. All other content is entering into the db OK. Therefore, I can only assume that I am either doing something wrong with the Update Record process, or, I am in fact doing it correctly, but the code is broken.

If I load a new image to update the file field content via the update page, then the db field is populated with the correct info.

Actually, can I have you promote this to a support ticket please?

Sign in to reply to this post

contact318852

Sorry for butting into your thread,

I assumed our issues were the same bug... I didnt realize the confusion it would cause.

I will post in another thread.

Sign in to reply to this post

Dani Chankhour

Originally Said By: mrs
  Brian, who was that reply to?

As far as I am aware I posted a request for help and I haven't seen anything that is helping me!

When I do an update, the fields, radio buttons, menus etc whatever they be are populated correctly. I have even tested the page before turning the text field into a hidden field and it is getting populated...

So, on that basis, when I turn the text field to a hidden field, it should be getting db info, but it is in the process of submitting that the hidden form content is being erased and is giving me a blank db field. All other content is entering into the db OK. Therefore, I can only assume that I am either doing something wrong with the Update Record process, or, I am in fact doing it correctly, but the code is broken.

If I load a new image to update the file field content via the update page, then the db field is populated with the correct info.

Actually, can I have you promote this to a support ticket please?  



Yes, i can open a support ticket if if you are still experiencing the issue.

But before, i would like to try one other thing. In the Upload Server behavior try binding the Default file to the 'mainimage' column from your record set. this way if no new image is used then the DataAssist Server Behavior should use the default image which you get from the record set.

Let me know if you still have questions.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...