close ad
Help us test the new Databridge BETA with MySQLi support
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

user_EmailPW.php not sending e-mail

Thread began 11/08/2009 4:56 pm by rjpeterson3359345 | Last modified 1/14/2010 6:23 pm by jim286478 | 1391 views | 6 replies |

rjpeterson3359345

user_EmailPW.php not sending e-mail

After running the security assist wizard the resulting forgot password e-mail function does not work.

If an incorrect password is entered on the user_login.php page, the user is taken to the user_EmailPW.php page where the user enters their e-mail address. If the e-mail is valid, an e-mail is sent and the user is returned to the login page. The error I'm seeing is the e-mail is never sent or received. I know the new password is stored to the database because I'm no longer able to log in using it.

Thanks,
Rick

Sign in to reply to this post

Jason ByrnesWebAssist

Please send a copy of the user_EmailPW.php page.

Sign in to reply to this post

rjpeterson3359345

user_EmailPW.php not sending e-mail

Jason,
Please find the attached file.
Rick

Attached Files
user_EmailPW.php.zip
Sign in to reply to this post

Jason ByrnesWebAssist

Does your host support sending emails using the mail() function in PHP?


In the Email Password server behavior, try leaving the SMTP server blank.

Also try leaving the From Display name Blank.

If the email is still not being sent, ask the host if they can provide a sample script for sending email in PHP using the mail() command, they may require modifying the mail() function to pass an additional parameter. If they can provide a sample script, I will be able to see if there is some change needed to the email password code.

Sign in to reply to this post

jim286478

Sorry I am not posting a solution! And I am not sure if I should be posting here, however, I have a very similar problem so I thought the answers maybe the same. I have one form being emailed by UE fine. I have a forgot password not being emailed. Both use the same server name and port number and both are on the same host server and the same domain. I would appreciate some help.
Jim

Attached Files
SE_issue.zip
Sign in to reply to this post

Jason ByrnesWebAssist

In the forgot.php page, the from address is not a valid email address:
"fromAddress" => "NACBC",

most SMTP server will not relay the email if the from address is not a valid email address.

Sign in to reply to this post

jim286478

Jason, thank you, that was the problem.
Jim

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...