close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

I'm on a Mac...

Thread began 4/22/2009 12:26 pm by mark282611 | Last modified 9/03/2009 1:36 pm by Justin Nemeth | 3955 views | 9 replies |

mark282611

I'm on a Mac...

...using DW CS3 and have loads of WebAssist extensions, just downloaded the Contact Form Solutions Pack and saw the beginners guide to setting up a database and thought "YAY! At Last!" as I am a designer and have no clue about databses although I would like to/need to get my head round it.

However, it's all for Windows.

Is there ANYONE that can shed some light on working with databases on a Mac??? (a G5 2Ghz Dual Processor running OSX 10.4.11)

Has to be a really step-by-step setup for dummies type of thing, I really have no clue about databases - but I am a fast learner.

All/any help much appreciated

Sign in to reply to this post

Ray BorduinWebAssist

Have you looked at the WebAssist Database starter kit? It should walk you through many of the basics you would need.

Sign in to reply to this post

Justin Nemeth

If you want to get a quick web server and MySQL database server running, check out MAMP - index.html. That should get your test environment up and running quickly to dive in. Using the DB starter kit will walk you through the basics.

Sign in to reply to this post

mark282611

Cheers guys - I'd overlooked that as it isn't in with the contact form thing.

Will have a run through with both and see if it points me in the right direction!

Thanks again.

Sign in to reply to this post

susan.pro374869

mySQL and sodu command in Terminal

I followed the directions in your "How to install PHP/MySQL on Mac OS 10.5"
All was well until the very last step of changing password. I typed a " instead of an ' and hit return. Now when I open terminal and try to type any sort of a command, nothing happens. There is no blinking cursor, nothing. I am a newbie and afraid I a have screwed up my Mac by being an ignorant sodu commander.

I have no idea what to do. My goal is to make an online store with DW CS4. I bought the Web Developer Suite but am a neophyte who has spent two days on the very first step of trying to set up a testing server. I am in a bad place.

Can anyone help me with my sodu Terminal woes?

Sign in to reply to this post

Justin Nemeth

In terminal pressing Control-C will exit from your current command. You should also be able to copy/paste the commands into terminal if that is easier than typing them out.

Sign in to reply to this post

gregurke385889

Making DB connection similar problem but not solved

Hi again as you mentioned above sometimes re-doing the steps fixes the issue.

I have re-done the step about 10 times and can't seem to get a result. I have attached picture1 to this message as it is a long one but basically it is telling me that no testing server is running - yet I have MAMP telling me it is all good, and also when I go to the details in the testing server for the site it sets it for me (see attachment picture2).

what the?

cheers
DG

Sign in to reply to this post

Justin Nemeth

It looks like DW is looking for the script in the root of you mamp site, based on picture 1. It also looks like your testing server is set to a sub folder within the mamp site. Its possible DW is putting the files in that directory instead of the root.

Can you find the _mmServerScripts anywhere in your web directory? If so, try moving it to the web root and that should fix the problem.

Sign in to reply to this post

gregurke385889

MM server script folder still not linking

thanks for the reply but I have moved that mm folder and it made no difference. Exact same error message.

I have followed the install locations anyway so I don't get why this is a problem?
I moved the e-learning folder to the sites folder. Even when I move the mm server folder out it auto regenerates itself there anyway.

is there some form of manual you have for mac installs? i am getting desperate aaaaaaaaahhhhh

thanks in advance
Dave

PS interesting weird thing. If I manually eneter the name"physical_goods" and press ok it allows the db to load, although I can't edit it. see attchment to see what it comes up as. Does this possibly explain anything you may have experienced?

Sign in to reply to this post

Justin Nemeth

Are you using MAMP or the build in apache server as yor webserver on your mac? It seems like its an issue with the path to your web folder and/or testing server.

Here is how I normally set it up, so verify yours is similar.

Choose a local site folder in your /Sites/ somewhere. For the testing server, choose you server language (likely php), then choose the same local folder there. In the testing server url, make sure the path is correct (i.e. myfolder).

If that doesn't work properly, my guess is it a config issue with your web server. And its even possible you have MAMP and the build in web server running at the same time. If you have both running, you might need to double check your site root for MAMP since it might be set to something besides /Sites/ and it also might be running on another port.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...