close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Test mode

Thread began 4/16/2009 2:54 pm by stevesmith373400 | Last modified 6/18/2009 7:37 pm by jasonkline326722 | 2819 views | 7 replies |

stevesmith373400

Test mode

Does anyone know about a "test mode" in the shopping cart. I place an order and get a receipt from Authorize.net saying that it is intest mode and the funds are not processed. It would be processed fine if it were not in test mode. I have turned off the test mode in Authorize.net. Their support says that somewhere in my cart software is a test mode setting that needs to be turned off. Thansk for the help.

Sign in to reply to this post

Ray BorduinWebAssist

On your confirm page, search for the word "test" and you should be able to see where it is set to true and can be updated to false.

You can also find it in the local checkout server behavior settings.

Sign in to reply to this post

Jon GibsonBeta Tester

Answer

Hello Steve:

SOLUTION:
1. In confirm.php, open Code View.
2. About line 149 or so, you should see this line:
$AuthNet_required[0][$nextIndex] = "x_test_request";
$AuthNet_required[1][$nextIndex] = "TRUE";
3. Change the "TRUE" value to "FALSE"

Also, if you search for "Powerful Product for Simple Problem" you will find many answers to your questions and more. Authorize.net was tough to get going, but Ray definitely helped! Anyway, I think that post was a pretty decent summary of the information used.

Hope that helps!
Jon

Sign in to reply to this post

veronica.reid341765

Authorize.net

I'm trying to build the same kind of ecart solution selling 3 subscriptions and I also have authorize.net.

Is there any way you can help me work through this process. I'm about ready to lose my marbles.

Veronica

Sign in to reply to this post

Ray BorduinWebAssist

Please start a new thread. Explain exactly what you are doing and where you are stuck and we can try to help.

Sign in to reply to this post

jasonkline326722

I got this working after changing to FALSE.

But before I could submit the order by pressing the order button on the order confirmation page, I recieve an email merchant email receipt. It looks like my card was charged before I could confirm. Is this by design or is this a BUG.

Sign in to reply to this post

Ray BorduinWebAssist

That would be a bug. It shouldn't charge until you hit the final confirm button on the confirm page. I'm not sure what could have caused this... it is not a common problem or known issue.

Sign in to reply to this post

jasonkline326722

That is scary. I have updated a ticket about this problem.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...