close ad
WARNING: Do Not Install the DREAMWEAVER CC 2017 or 2018 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Trouble creating div within div

Thread began 10/21/2009 9:09 am by mrs | Last modified 12/16/2009 5:25 pm by Jimmy Wu | 4451 views | 15 replies |

mrs

Trouble creating div within div

I have got a problem with CSS Sculptor 3 where I am trying to create a div within a div... actually, it is within four divs!

I have divs named and in this order:

footer, footerWrapper, footerTop, footerButtons... and then this is where the problem is coming in!

I am trying to create one further div where I am hoping to call it footerButtonMiddle, but any name I try to give it reverts back to div. Any settings I give it are not taken on board, and the preview is not registering the changes either. Is there any reason for this, or is it a glitch in the software?

Thanks.

Sign in to reply to this post

mrs

I have just looked at the css code created, and the divs that are five layers down did create, but only with the default name of div1 or div2 (despite what I attempted to call them) and they did retain and the attributes that I specified, but for some reason, even though it visually looked to be in the right position of footer, footerWrapper, footerTop, footerButtons, div1 the css code created with it at the top level under outerWrapper, div1

Is it wrong to have this many divs inside each other? Is that why it doesn't work?

Sign in to reply to this post

Dani Chankhour

When you created the nested divs, were you able to see the names of the divs changes in the tree structure. You might need to click on the tree structure in order to save the changes.

Sign in to reply to this post

mike271728

Im getting the same problem with CSS S 3.0
Clicking doesnt help neither does restartng it seems that you can add X amount of Divs then it stops aloowing renames.

Also no the names do not change in the tree structure.

Sign in to reply to this post

mike271728

Any news WA on a fix or cause of this?

Sign in to reply to this post

Jason ByrnesWebAssist

I am not able to reproduce the problem.

I created 25 divs, each one I was able to rename.

My steps where to select the contentWrapper div in the tree, then click the plus button and select div. In the Name box I would change the name of the div, for testing i was using div<n> where n is a number. Then select the div above it in the tree (for example the content div) to see the name change take effect in the tree structure.


How many divs are you adding?
What are the steps you are taking?

Sign in to reply to this post

MikeH

Personally Im doing the same thing as you only added around 5 divs and renaming stops.

Sign in to reply to this post

MikeH

Ive just retried just make sure Im not missing something I now can not add more divs and certainly no renaiming..

I am using the latest build.

Getting frustrated as I habe not had trouble with Sculptor previously so now its causing a hold up.

To add a little more strangeness to this issue, I have just tried with a new design and you are right I can add as many Divs as I want and they all rename no problem.

As soon as I go back to my design it fails again. I have not edited any files outside of the interface so it seems very odd why this CSS Design has stopped alowwing functions. Any ideas appreciated.

Sign in to reply to this post

MikeH

Right recreated all my work from scratch and all was well but then Sculptor decides that it will start doing odd behaviour again with not showing correct settings for Divs and selecting the wrong ones.

Sign in to reply to this post

jonathan395400

Problem Creating Divs

Hi All,
I am posting here as my own issue appears to be simillar. Scupltor 3 and when I first modify a design layout by adding further divs all is OK. I save it as a present, but when I then try to add divs by modifying the new preset that I have created I get all types of issues:
Creates the default div, but loads values from another div further up the tree including name. Changing name only changes the div from further up the tree that was initially pulled in and leaves a default div which I can not edit its properties destroying the design in the process.

Very frustrating to the extent that I have now ditched Sculptor 3 and gone back to hand coding.

I have made a ScreenCasst of the issue for you all to look at.

WebAssist.html

Does anyone have a fix or solution to the above.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...