close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Not sending email to more than 1 user

Thread began 4/14/2009 10:29 am by lesdekock317136 | Last modified 6/17/2009 12:06 pm by Stan | 2974 views | 8 replies |

lesdekock317136

Not sending email to more than 1 user

I used the standard wizard to set up universal email.

I've run close on 30 tests now, and in each case the email appears to send to only one person. Either the end customer OR my client OR me, but always only one of us. I've checked my spam and the ISP says there is nothing on his side that should impact on a cc.

The email when it arrives says that the other two email addresses are cc'd.

Does anyone have any ideas.

I'm also having a real problem as soon as I don't use plain text but that's less of an urgent issue.

Sign in to reply to this post

lesdekock317136

not working at all now :-(

And now its not working at all. I deleted the whole of universal email, and rebuilt everything, it sent one email, and then "broke" again.

Is this extension actually working for anyone? Has anyone ever set it up to work to send email to more than one person?

Sign in to reply to this post

Ray BorduinWebAssist

It works all the time for lots of people. You would need to debug the issue. It is possible CC isn't working for some reason. What version of php are you using. I can see there is a bug in php on windows in version 4.0.4 that prevents CC from working. Does that describe your server?

Sign in to reply to this post

lesdekock317136

I only have the phpinfo information. Please let me know what other lines might be useful.

System: Windows NT REACTORA 5.2 build 3790
Microsoft-IIS/6.0

I've tried using the standard mail, as well as Pear. I've removed everything except a single email "to" (no workflow etc), and I can't get it to work at all any more. I deleted the Universal email, and the related folder and redid it. I've sent about 20 emails with different settings and to different email addresses - from gmail to the normal ones - they can't ALL be blocked by spam filters every time.

It was working with one email erratically earlier today. I'm actually going backwards!

So please, any ideas where I can start looking for the problem would be gratefully received.

Sign in to reply to this post

lesdekock317136

Can I use another mail server

If there could be an issue with this mail server, could I use a mail server from one of my other websites to send the email?

Sign in to reply to this post

Ray BorduinWebAssist

Usually they have permissions preventing that. What are you specifying in the smtp server field? Try leaving it blank and it will use the default smtp server for that php installation.

You can also add debug code to see if there is an error or if the code is functioning properly and the problem is with the smtp server.

In the file mail_PHP.php, add code below the line:

$mailObj = mail($mailTo,$mailSubject,$mailContent,$mailHeader);

so it becomes:

$mailObj = mail($mailTo,$mailSubject,$mailContent,$mailHeader);
var_dump($mailObj);
die();

This will tell you whether the php script thinks the email was sent properly. From there it may be a problem with the smtp server (although it returned no errors) or more likely a spam filter.

Sign in to reply to this post

lesdekock317136

No progress

I tried this and the returned page was bool(true).

I've redone the application on a different server with much the same result. The second insert record did send 2 emails, but since then I have received none. The Client is the first email address on the list, and that one is possibly going through, but none of the others has arrived. Two are direct email addresses, one is the email address from a field. I've tried changing the order in case one is failing. I'm still not entirely certain the client's email is going through, although I hope so.

I used this extension for another client, and when I got the test emails I assumed it was fine. However I'm now very worried that he hasn't been getting his emails either.

Sign in to reply to this post

Ray BorduinWebAssist

Please try submitting a support incident and somebody can help you debug the problem.

If it says bool(true) it means that it sent the email to the email server and no errors were reported. This usually means the email went through and that the problem is with a spam filter.

Sign in to reply to this post

Stan

There is actually an alternative which works very well. I mention it here because it is a dumbed down version of UE, but it has the advantage of being open to changes. I know that some of the other developers here are using it. It allows smtp with authentication to any mail server that you have an account on. As you may recall Ray, I was having issues with my ISP over authentication and this is the solution I found:
phpmailer.sourceforge.net/

Con:
No easy interface like UE has.
Requires at least some knowledge of PHP coding.

Pro:
Works with ANY email server anywhere you have an account.
Can be tweaked and customized if you know some PHP.

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...