close ad
Install the LAtest Updates to Work with CC 2017 and CC 2018
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Problem when I transfer to the live server

Thread began 10/09/2009 5:46 am by david385393 | Last modified 10/12/2009 1:45 pm by Dave Buchholz | 905 views | 4 replies |

david385393

Problem when I transfer to the live server

I wonder if someone could advise me as to possible causes for the following. I am using DataAssist with Dreamweaver CS3. I have created the pages for the MySQL table, eg. Search, Results, Update, Delete,Insert and Detail. Everything seems to work perfectly on the testing server (WAMP). When I upload the files and the folders WA_DataAssist and WADbSearch to the live server I update the connection file to the info needed for the live server and also update the link to the connection.php file at the start of each page Search and Results etc.
When I load the pages through my browser, eg. the Insert page, When I put in some data and click insert, Nothing happens. The form goes from the screen and I am left with a blank white browser screen. When I load the Search page and input the details I get the same effect when I click on search. As one would guess, when I check the database through phpMyAdmin, nothing has been passed to the table.


My testing Server - PHP Ver 5.3.0, Apache Ver 2.2.11 and MySQL 5.1.36.

My Live Server - PHP Ver 5.2.5, Apache Ver 1.3.41 and MySQL 4.1.7 ( MySQL has the following mysql.allow_persistent off) This could be prob?

Any advise would be appreciated

Thanks

Sign in to reply to this post

Dave BuchholzBeta Tester

the fact that you have a blank white screen suggests a php error, add this code to the top of the page:

<?php
error_reporting(E_ALL);
ini_set('display_errors', '1');
?>



and this will display error messages that will help debug the issues your having

Sign in to reply to this post

david385393

Thanks

Thanks for advise, I'll try that.

Sign in to reply to this post

david385393

Thanks Again

Dave Buchholz,
Thanks for that advise. I included the code in each page and found that eventhough I had changes the database connection at the top of each page to link to the live server connection file, I had overlooked several other parts of code which were still looking for the testing server. Changed all the necessary info and it is now working fine.

Cheers

David

Sign in to reply to this post

Dave BuchholzBeta Tester

excellent, glad you got it sorted

Sign in to reply to this post

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...