close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Applying encryption with Security Assist and Data Assist

Thread began 10/07/2009 1:06 pm by David Stringer | Last modified 10/09/2009 10:24 am by Ray Borduin | 2649 views | 11 replies |

David StringerBeta Tester

Applying encryption with Security Assist and Data Assist

I am endeavouring to apply encryption to a particular site I had originally used Addt on. I have removed all the code that appertained from that programme!

I am presently testing the pages on my local machine.

Having built the necessary pages, following exactly the Solution Recipes in SA, I keep getting the same problem. Having added the php error reporting to the page, the page returns the following error:

Warning: require_once(../WA_SecurityAssist/WA_SHA1Encryption.php) [function.require-once]: failed to open stream: No such file or directory in C:\wamp\www\UpsallStud\assets\users_Registration.php on line 6

Fatal error: require_once() [function.require]: Failed opening required '../WA_SecurityAssist/WA_SHA1Encryption.php' (include_path='.;C:\php5\pear') in C:\wamp\www\UpsallStud\assets\users_Registration.php on line 6

Checking my files - there is no SHA1Enryption.php page to be found.

Thinking I could circumvent this by downloading the Security Assist extension again and disposing of the winfilecache.dat file, I did so. Unfortunately, this didn't help one jot!

Has anyone any ideas on what might be going wrong?

EDIT: I've noticed that in the file extension, it has shown the ph with one space and then p, but this is alright in the code that I cut and pasted!!

Sign in to reply to this post

jenkolaka19379118

For some very strange reason this happened to me too. I had to copy the SHA1.php file from another site and paste it into my current sa folder in my web directory

Sign in to reply to this post

David StringerBeta Tester

Unfortunately, I've never used this programme until now, so don't have the luxury of being able to copy it from anywhere. I presume that it is generated on the hoof! I shall have to wait until someone from WebAssist sees my plight and provides an answer.

Thank you for your observations.

Sign in to reply to this post

Ray BorduinWebAssist

You could try adding encryption to another page.

You could search your DW configuration for that file and copy it from there.

It should copy it as it writes the file to your page. Make sure the page you add it to is saved and in a php defined site and it should copy the file automatically.

Sign in to reply to this post

Ray BorduinWebAssist

You could try adding encryption to another page.

You could search your DW configuration for that file and copy it from there.

It should copy it as it writes the file to your page. Make sure the page you add it to is saved and in a php defined site and it should copy the file automatically.

Sign in to reply to this post

Jason ByrnesWebAssist

Here is a zip file that contains the needed file. Copy the file from the zip file to the WA_SecurityAssist Folder.

Attached Files
securityAssistFiles.zip
Sign in to reply to this post

David StringerBeta Tester

Originally Said By: Jason Byrnes
  Here is a zip file that contains the needed file. Copy the file from the zip file to the WA_SecurityAssist Folder.  



Hi Jason,

Thank you for this. I've downloaded the files and will have a play with them tomorrow. Too late to be doing it now!

I did try to copy the files to the folder in my site and was told by Windows that they were there. I assure you, they were not unless they were hidden. I used Windows Explorer to copy them to the page in the folder and they then did appear in DW. Weird goings-on!

I'll let you know how I get on.

Sign in to reply to this post

David StringerBeta Tester

Bug?

I have copied the files as explained and everything is working OK now. Thank You.

I cannot help but think that there might be a bug which is not allowing the programme to write the necessary details to disc. Only because this has occurred on two separate computers, not just one. OR there is something wrong with my computers.:rolleyes:

Sign in to reply to this post

Ray BorduinWebAssist

Yes, you are not the first to report it either, so I think it might be a bug. I'll try to do some testing to see if I can reproduce it. What version of Dreamweaver and operating system were you using?

Were you dragging and dropping, or clicking a lightning bolt, or clicking the insert button in the bindings panel to add it to the page?

Most likely the issue is specific to the exact usage scenario you were going through and knowing that might help me correct it.

Sign in to reply to this post

David StringerBeta Tester

Hi Ray,

I'm using Dreamweaver CS4 and XP Pro.

Just to make it easy for you, I was following Mark's Solution Recipes under the Support & Training. (To the letter!!) I don't suppose you've seen them though. Not sure on every move I made, but there were no drags and drops!
Hope this helps.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...