close ad
WARNING PC USERS: Do Not Install the DREAMWEAVER CC 2017 Update »
open ad
View Menu

Technical Support Forums

Free, outstanding support from WebAssist and your colleagues

rating

Site Import fails to import most of site!

Thread began 4/07/2009 12:39 pm by dvolle228412 | Last modified 8/24/2009 6:57 pm by Ray Borduin | 3512 views | 9 replies |

dvolle228412

Site Import fails to import most of site!

I'm wondering, is there is a fix to a problem I'm finding?
Site import fails to import most of the site on some sites because it won't follow any link that is set to a directory instead of a specific page.
For Example if the site looks like this
domain/index.htm
links:
domain/products/
domain/services/
domain/aboutus/
the net effect is that while the site may consist of 100s of pages in each sub directory, only the home page is imported.
Of course this makes the tool worthless for a site stuctured this way, and it isn't unusual.

Sign in to reply to this post

Ray BorduinWebAssist

I believe it should work for those links provided they are in a common link location like an href="" tag. Do you have an example site page with a link it does not follow properly?

Sign in to reply to this post

dvolle228412

Example link

Sure, try to import www.varelintl.com/ and see what happens, I don't get anything except the index.htm from the home page, but both of the sub sites are linked as href on that page.
I'm using CS4 with SiteImport 3.01

Sign in to reply to this post

dvolle228412

Is there a fix?

I'm still wondering if there is a fix?
At present the tool fails to do basic site downloads if navigation includes directory links.

Sign in to reply to this post

Danilo Celic

Sorry for the delay...

I've checked the site you supplied and I can confirm that this is an issue with SiteImport. It should be recognizing this type of linking. I'll be checking into the code to see where SiteImport should be finding these links to add to the list of files to download. I'll post back when I've been able to get a fix checked in. From there we'll need to do a little testing to insure that we didn't introduce any other issues with the fix, we'll then get a new build out to users. Just to let you know that will be at least a few days once we've identified a solution before a new build will be distributed, but I will keep this thread updated.

Sign in to reply to this post

dvolle228412

Thanks I'll be waiting.

Thanks for the update, I'll be waiting, the product really needs this fix.

Sign in to reply to this post

dvolle228412

Still Hoping for a fix

I'm still hoping for a fix. About 2 weeks has gone since the last post to this thread, and the product is still unusable.
Please inform of any pending updates to this product, is a solution in the works?
When can we expect to see it?
Thank You.

Sign in to reply to this post

Ray BorduinWebAssist

A solution is in the works, but it won't be immediate because it will need to pass through our QA process and since it was not a planned update it is back in the queue. It may be a couple of months before a public build is available.

You may be able to contact support to get a replacement for the file that causes the problem. The update was made to: floaters/wa_progress/processing objects/ shared.js.

Although we don't like to give out files before complete QA is done, I believe they can send you the file with a disclaimer that it may not work to help a customer when the product isn't working for them entirely. I'd try to post a support incident and ask for an updated version of that file if you can't wait a couple of months for the update to be live.

Sign in to reply to this post

Sara_Jean387643

This didn't work for me either.

I bought this software to download a site that was created for me. The web designer flaked out and we need to move the site. We are having the same problem as the person that originally posted this. Please advise as to how to proceed. If I can't resolve this today I would like a refund. the site is sarajeandesigns.com.

Thanks

Sign in to reply to this post

Ray BorduinWebAssist

I have created an incident to look into this with you further. View and respond to your incident at supporthistory.php

You can also request a refund directly in a reply to that incident.

Sign in to reply to this post
loading

Build websites with a little help from your friends

Your friends over here at WebAssist! These Dreamweaver extensions will assist you in building unlimited, custom websites.

Build websites from already-built web applications

These out-of-the-box solutions provide you proven, tested applications that can be up and running now.  Build a store, a gallery, or a web-based email solution.

Want your website pre-built and hosted?

Close Windowclose

Rate your experience or provide feedback on this page

Account or customer service questions?
Please user our contact form.

Need technical support?
Please visit support to ask a question

Content

rating

Layout

rating

Ease of use

rating

security code refresh image

We do not respond to comments submitted from this page directly, but we do read and analyze any feedback and will use it to help make your experience better in the future.

Close Windowclose

We were unable to retrieve the attached file

Close Windowclose

Attach and remove files

add attachmentAdd attachment
Close Windowclose

Enter the URL you would like to link to in your post

Close Windowclose

This is how you use right click RTF editing

Enable right click RTF editing option allows you to add html markup into your tutorial such as images, bulleted lists, files and more...

-- click to close --

Uploading file...